mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
28 lines
1.1 KiB
Diff
28 lines
1.1 KiB
Diff
diff -ruN a/auxiliary_files/CMakeLists.txt b/auxiliary_files/CMakeLists.txt
|
|
--- a/auxiliary_files/CMakeLists.txt 2023-01-18 07:54:18.355957000 +0100
|
|
+++ b/auxiliary_files/CMakeLists.txt 2023-01-22 00:35:54.387905181 +0100
|
|
@@ -64,22 +64,12 @@
|
|
file(COPY "config_files/mumble-server.conf" DESTINATION ${CMAKE_CURRENT_BINARY_DIR})
|
|
|
|
if(UNIX AND NOT APPLE)
|
|
- get_pkgconf_variable(
|
|
- OUTPUT_VARIABLE SYSUSERS_DIR
|
|
- MODULE systemd
|
|
- VARIABLE_NAME sysusersdir
|
|
- QUIET
|
|
- )
|
|
+ pkg_get_variable(SYSUSERS_DIR systemd sysusersdir)
|
|
if(NOT SYSUSERS_DIR)
|
|
# Fallback value, in case it could not be fetched via pkg-config
|
|
set(SYSUSERS_DIR "${CMAKE_INSTALL_SYSCONFDIR}/sysconfig.d")
|
|
endif()
|
|
- get_pkgconf_variable(
|
|
- OUTPUT_VARIABLE SYSTEMD_SERVICE_DIR
|
|
- MODULE systemd
|
|
- VARIABLE_NAME systemd_system_unit_dir
|
|
- QUIET
|
|
- )
|
|
+ pkg_get_variable(SYSTEMD_SERVICE_DIR systemd systemd_system_unit_dir)
|
|
if(NOT SYSTEMD_SERVICE_DIR)
|
|
# Default to /etc/systemd/system - This is not where packages ought to install their service files (rather
|
|
# it's where an admin is supposed to add their system files), but this seems to be the most consistent
|