mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
62 lines
2.4 KiB
Diff
62 lines
2.4 KiB
Diff
From 14948e9d7bdb5cc7e975c1f3435692eeb748f07b Mon Sep 17 00:00:00 2001
|
|
From: Josh Stone <jistone@redhat.com>
|
|
Date: Fri, 27 Sep 2019 12:33:08 -0700
|
|
Subject: [PATCH] [WIP] minimize the rust-std component
|
|
|
|
---
|
|
src/bootstrap/dist.rs | 33 +++++++++------------------------
|
|
1 file changed, 9 insertions(+), 24 deletions(-)
|
|
|
|
diff --git a/src/bootstrap/dist.rs b/src/bootstrap/dist.rs
|
|
index d9dff77a30e..bd96a6371fc 100644
|
|
--- a/src/bootstrap/dist.rs
|
|
+++ b/src/bootstrap/dist.rs
|
|
@@ -675,36 +675,21 @@ impl Step for Std {
|
|
return distdir(builder).join(format!("{}-{}.tar.gz", name, target));
|
|
}
|
|
|
|
- // We want to package up as many target libraries as possible
|
|
- // for the `rust-std` package, so if this is a host target we
|
|
- // depend on librustc and otherwise we just depend on libtest.
|
|
- if builder.hosts.iter().any(|t| t == target) {
|
|
- builder.ensure(compile::Rustc { compiler, target });
|
|
- } else {
|
|
- builder.ensure(compile::Std { compiler, target });
|
|
- }
|
|
+ builder.ensure(compile::Std { compiler, target });
|
|
|
|
let image = tmpdir(builder).join(format!("{}-{}-image", name, target));
|
|
let _ = fs::remove_dir_all(&image);
|
|
|
|
- let dst = image.join("lib/rustlib").join(target);
|
|
+ let dst = image.join("lib/rustlib").join(target).join("lib");
|
|
t!(fs::create_dir_all(&dst));
|
|
- let mut src = builder.sysroot_libdir(compiler, target).to_path_buf();
|
|
- src.pop(); // Remove the trailing /lib folder from the sysroot_libdir
|
|
- builder.cp_filtered(&src, &dst, &|path| {
|
|
- if let Some(name) = path.file_name().and_then(|s| s.to_str()) {
|
|
- if name == builder.config.rust_codegen_backends_dir.as_str() {
|
|
- return false
|
|
- }
|
|
- if name == "bin" {
|
|
- return false
|
|
- }
|
|
- if name.contains("LLVM") {
|
|
- return false
|
|
- }
|
|
+
|
|
+ let compiler_to_use = builder.compiler_for(compiler.stage, compiler.host, target);
|
|
+ let stamp = dbg!(compile::libstd_stamp(builder, compiler_to_use, target));
|
|
+ for (path, host) in builder.read_stamp_file(&stamp) {
|
|
+ if !host {
|
|
+ builder.copy(&path, &dst.join(path.file_name().unwrap()));
|
|
}
|
|
- true
|
|
- });
|
|
+ }
|
|
|
|
let mut cmd = rust_installer(builder);
|
|
cmd.arg("generate")
|
|
--
|
|
2.24.0
|
|
|