mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
41 lines
1.5 KiB
Diff
41 lines
1.5 KiB
Diff
From a7614e48179e101c7f41032ba54a6f3e637da629 Mon Sep 17 00:00:00 2001
|
|
From: Victor Gu <xigu@marvell.com>
|
|
Date: Fri, 8 Sep 2017 11:53:46 +0200
|
|
Subject: [PATCH 2/3] PCI: aardvark: disable LOS state by default
|
|
|
|
Some PCIe devices do not support LOS, and will cause timeouts if the
|
|
root complex forces the LOS state. This patch disables the LOS state
|
|
by default.
|
|
|
|
This is part of fixing bug
|
|
https://bugzilla.kernel.org/show_bug.cgi?id=196339, this commit was
|
|
reported as the user to be important to get a Intel 7260 mini-PCIe
|
|
WiFi card working.
|
|
|
|
Fixes: 8c39d710363c1 ("PCI: aardvark: Add Aardvark PCI host controller driver")
|
|
Signed-off-by: Victor Gu <xigu@marvell.com>
|
|
Reviewed-by: Evan Wang <xswang@marvell.com>
|
|
Reviewed-by: Nadav Haklai <nadavh@marvell.com>
|
|
[Thomas: tweak commit log.]
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
drivers/pci/controller/pci-aardvark.c | 3 +--
|
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
|
|
|
diff --git a/drivers/pci/controller/pci-aardvark.c b/drivers/pci/controller/pci-aardvark.c
|
|
index 750081c1cb48..1154f0da0410 100644
|
|
--- a/drivers/pci/controller/pci-aardvark.c
|
|
+++ b/drivers/pci/controller/pci-aardvark.c
|
|
@@ -331,8 +331,7 @@ static void advk_pcie_setup_hw(struct advk_pcie *pcie)
|
|
|
|
advk_pcie_wait_for_link(pcie);
|
|
|
|
- reg = PCIE_CORE_LINK_L0S_ENTRY |
|
|
- (1 << PCIE_CORE_LINK_WIDTH_SHIFT);
|
|
+ reg = (1 << PCIE_CORE_LINK_WIDTH_SHIFT);
|
|
advk_writel(pcie, reg, PCIE_CORE_LINK_CTRL_STAT_REG);
|
|
|
|
reg = advk_readl(pcie, PCIE_CORE_CMD_STATUS_REG);
|
|
--
|
|
2.20.1
|
|
|