mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
16 lines
621 B
Diff
16 lines
621 B
Diff
diff --git a/lib/core/src/perl/RefHash.xxs b/lib/core/src/perl/RefHash.xxs
|
|
index 42ee53cd..5cc3f73f 100644
|
|
--- a/lib/core/src/perl/RefHash.xxs
|
|
+++ b/lib/core/src/perl/RefHash.xxs
|
|
@@ -71,7 +71,11 @@ SV* tmp_keysv::set(SV* keysv)
|
|
Copy(obj.keyp, HEK_KEY(hekp), sizeof(SV*), char);
|
|
HEK_LEN(hekp) = sizeof(SV*);
|
|
HEK_HASH(hekp) = U32(obj.keyl >> 4); // hash value
|
|
+#if PerlVersion >= 5360
|
|
+ HEK_FLAGS(hekp) = HVhek_NOTSHARED;
|
|
+#else
|
|
HEK_FLAGS(hekp) = HVhek_UNSHARED;
|
|
+#endif
|
|
sv.sv_any = &xpv;
|
|
sv.sv_refcnt = 1;
|
|
sv.sv_flags = SVt_PVIV | SVf_IVisUV | SVf_POK | SVp_POK | PmFlagsForHashKey;
|