PKGBUILDs/core/kernel26/LEDs.patch
2011-01-27 23:50:11 -06:00

194 lines
5.5 KiB
Diff

diff -urN a//arch/arm/mach-kirkwood/goflexnet-setup.c b//arch/arm/mach-kirkwood/goflexnet-setup.c
--- a//arch/arm/mach-kirkwood/goflexnet-setup.c 1969-12-31 17:00:00.000000000 -0700
+++ b//arch/arm/mach-kirkwood/goflexnet-setup.c 2010-12-18 00:50:13.369176001 -0700
@@ -0,0 +1,121 @@
+/*
+ * arch/arm/mach-kirkwood/goflexnet-setup.c
+ *
+ * Seagate Goflex Net Setup
+ *
+ * This file is licensed under the terms of the GNU General Public
+ * License version 2. This program is licensed "as is" without any
+ * warranty of any kind, whether express or implied.
+ */
+
+#include <linux/kernel.h>
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/ata_platform.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mv643xx_eth.h>
+#include <linux/gpio.h>
+#include <linux/leds.h>
+#include <asm/mach-types.h>
+#include <asm/mach/arch.h>
+#include <mach/kirkwood.h>
+#include "common.h"
+#include "mpp.h"
+
+static struct mtd_partition goflexnet_nand_parts[] = {
+ {
+ .name = "u-boot",
+ .offset = 0,
+ .size = SZ_1M
+ }, {
+ .name = "uImage",
+ .offset = MTDPART_OFS_NXTBLK,
+ .size = SZ_4M
+ }, {
+ .name = "pogoplug",
+ .offset = MTDPART_OFS_NXTBLK,
+ .size = SZ_32M
+ }, {
+ .name = "root",
+ .offset = MTDPART_OFS_NXTBLK,
+ .size = MTDPART_SIZ_FULL
+ },
+};
+
+static struct mv643xx_eth_platform_data goflexnet_ge00_data = {
+ .phy_addr = MV643XX_ETH_PHY_ADDR(0),
+};
+
+static struct mv_sata_platform_data goflexnet_sata_data = {
+ .n_ports = 2,
+};
+
+static struct gpio_led goflexnet_led_pins[] = {
+ {
+ .name = "status:green:health",
+ .default_trigger = "default-on",
+ .gpio = 46,
+ .active_low = 1,
+ },
+ {
+ .name = "status:orange:fault",
+ .default_trigger = "none",
+ .gpio = 47,
+ .active_low = 1,
+ }
+};
+
+static struct gpio_led_platform_data goflexnet_led_data = {
+ .leds = goflexnet_led_pins,
+ .num_leds = ARRAY_SIZE(goflexnet_led_pins),
+};
+
+static struct platform_device goflexnet_leds = {
+ .name = "leds-gpio",
+ .id = -1,
+ .dev = {
+ .platform_data = &goflexnet_led_data,
+ }
+};
+
+static unsigned int goflexnet_mpp_config[] __initdata = {
+ MPP29_GPIO, /* USB Power Enable */
+ MPP47_GPIO, /* LED Orange */
+ MPP46_GPIO, /* LED Green */
+ 0
+};
+
+static void __init goflexnet_init(void)
+{
+ /*
+ * Basic setup. Needs to be called early.
+ */
+ kirkwood_init();
+
+ /* setup gpio pin select */
+ kirkwood_mpp_conf(goflexnet_mpp_config);
+
+ kirkwood_uart0_init();
+ kirkwood_nand_init(ARRAY_AND_SIZE(goflexnet_nand_parts), 25);
+
+ if (gpio_request(29, "USB Power Enable") != 0 ||
+ gpio_direction_output(29, 1) != 0)
+ printk(KERN_ERR "can't set up GPIO 29 (USB Power Enable)\n");
+ kirkwood_ehci_init();
+ kirkwood_ge00_init(&goflexnet_ge00_data);
+ kirkwood_sata_init(&goflexnet_sata_data);
+
+ platform_device_register(&goflexnet_leds);
+}
+
+MACHINE_START(GOFLEXNET, "Seagate Goflex Net")
+ /* Maintainer: Peter Carmichael <peterjncarm@ovi.com> */
+ .phys_io = KIRKWOOD_REGS_PHYS_BASE,
+ .io_pg_offst = ((KIRKWOOD_REGS_VIRT_BASE) >> 18) & 0xfffc,
+ .boot_params = 0x00000100,
+ .init_machine = goflexnet_init,
+ .map_io = kirkwood_map_io,
+ .init_irq = kirkwood_init_irq,
+ .timer = &kirkwood_timer,
+MACHINE_END
+
diff -urN a//arch/arm/mach-kirkwood/guruplug-setup.c b//arch/arm/mach-kirkwood/guruplug-setup.c
--- a//arch/arm/mach-kirkwood/guruplug-setup.c 2010-12-09 15:17:27.000000000 -0700
+++ b//arch/arm/mach-kirkwood/guruplug-setup.c 2010-12-18 00:50:13.409176002 -0700
@@ -19,7 +19,6 @@
#include <asm/mach-types.h>
#include <asm/mach/arch.h>
#include <mach/kirkwood.h>
-#include <plat/mvsdio.h>
#include "common.h"
#include "mpp.h"
@@ -57,12 +56,14 @@
static struct gpio_led guruplug_led_pins[] = {
{
- .name = "guruplug:red:health",
+ .name = "status:red:fault",
+ .default_trigger = "none",
.gpio = 46,
.active_low = 1,
},
{
- .name = "guruplug:green:health",
+ .name = "status:green:health",
+ .default_trigger = "default-on",
.gpio = 47,
.active_low = 1,
},
diff -urN a//arch/arm/mach-kirkwood/Kconfig b//arch/arm/mach-kirkwood/Kconfig
--- a//arch/arm/mach-kirkwood/Kconfig 2010-12-09 15:17:27.000000000 -0700
+++ b//arch/arm/mach-kirkwood/Kconfig 2010-12-18 00:50:13.369176001 -0700
@@ -64,6 +64,12 @@
QNAP TS-410, TS-410U, TS-419P and TS-419U Turbo NAS
devices.
+config MACH_GOFLEXNET
+ bool "Seagate GoFlex Net"
+ help
+ Say 'Y' here if you want your kernel to support the
+ Seagate GoFlex Net.
+
config MACH_OPENRD
bool
diff -urN a//arch/arm/mach-kirkwood/Makefile b//arch/arm/mach-kirkwood/Makefile
--- a//arch/arm/mach-kirkwood/Makefile 2010-12-09 15:17:27.000000000 -0700
+++ b//arch/arm/mach-kirkwood/Makefile 2010-12-18 00:50:13.369176001 -0700
@@ -9,6 +9,7 @@
obj-$(CONFIG_MACH_ESATA_SHEEVAPLUG) += sheevaplug-setup.o
obj-$(CONFIG_MACH_GURUPLUG) += guruplug-setup.o
obj-$(CONFIG_MACH_TS219) += ts219-setup.o tsx1x-common.o
+obj-$(CONFIG_MACH_GOFLEXNET) += goflexnet-setup.o
obj-$(CONFIG_MACH_TS41X) += ts41x-setup.o tsx1x-common.o
obj-$(CONFIG_MACH_OPENRD) += openrd-setup.o
obj-$(CONFIG_MACH_NETSPACE_V2) += netspace_v2-setup.o
diff -urN a//arch/arm/mach-kirkwood/sheevaplug-setup.c b//arch/arm/mach-kirkwood/sheevaplug-setup.c
--- a//arch/arm/mach-kirkwood/sheevaplug-setup.c 2010-12-09 15:17:27.000000000 -0700
+++ b//arch/arm/mach-kirkwood/sheevaplug-setup.c 2010-12-18 00:50:13.409176002 -0700
@@ -58,7 +58,7 @@
static struct gpio_led sheevaplug_led_pins[] = {
{
- .name = "plug:green:health",
+ .name = "status:green:health",
.default_trigger = "default-on",
.gpio = 49,
.active_low = 1,