PKGBUILDs/aur/cherokee/fix-ctk-path-handler-match.patch
2012-06-04 12:44:47 -04:00

17 lines
776 B
Diff

diff -upr cherokee-1.2.99.orig/admin/CTK/CTK/Server.py cherokee-1.2.99/admin/CTK/CTK/Server.py
--- cherokee-1.2.99.orig/admin/CTK/CTK/Server.py 2011-06-06 14:17:35.000000000 +0300
+++ cherokee-1.2.99/admin/CTK/CTK/Server.py 2011-09-16 03:31:06.000000000 +0300
@@ -121,8 +121,11 @@ class ServerHandler (pyscgi.SCGIHandler)
my_thread.scgi_conn = self
my_thread.request_url = url
+ # Drop the query string before matching against the handlers
+ path = url.split('?', 1)[0]
+
for published in server._web_paths:
- if re.match (published._regex, url):
+ if re.match (published._regex, path):
# POST
if published._method == 'POST':
post = self._process_post()