mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
58 lines
1.3 KiB
Diff
58 lines
1.3 KiB
Diff
From 95504f7bfc9c85d3148cec9c46084a8ab5e6ce8d Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Tue, 4 Jul 2017 11:54:39 -0600
|
|
Subject: [PATCH] ARM toolchain fixes
|
|
|
|
---
|
|
chromium/build/toolchain/linux/BUILD.gn | 24 ++++++++++--------------
|
|
1 file changed, 10 insertions(+), 14 deletions(-)
|
|
|
|
diff --git a/chromium/build/toolchain/linux/BUILD.gn b/chromium/build/toolchain/linux/BUILD.gn
|
|
index 86cd7dabc6..4b1e73b1ac 100644
|
|
--- a/chromium/build/toolchain/linux/BUILD.gn
|
|
+++ b/chromium/build/toolchain/linux/BUILD.gn
|
|
@@ -22,15 +22,13 @@ clang_toolchain("clang_arm64") {
|
|
}
|
|
|
|
gcc_toolchain("arm64") {
|
|
- toolprefix = "aarch64-linux-gnu-"
|
|
-
|
|
- cc = "${toolprefix}gcc"
|
|
- cxx = "${toolprefix}g++"
|
|
+ cc = "gcc"
|
|
+ cxx = "g++"
|
|
|
|
- ar = "${toolprefix}ar"
|
|
+ ar = "ar"
|
|
ld = cxx
|
|
- readelf = "${toolprefix}readelf"
|
|
- nm = "${toolprefix}nm"
|
|
+ readelf = "readelf"
|
|
+ nm = "nm"
|
|
|
|
toolchain_args = {
|
|
current_cpu = "arm64"
|
|
@@ -40,15 +38,13 @@ gcc_toolchain("arm64") {
|
|
}
|
|
|
|
gcc_toolchain("arm") {
|
|
- toolprefix = "arm-linux-gnueabihf-"
|
|
-
|
|
- cc = "${toolprefix}gcc"
|
|
- cxx = "${toolprefix}g++"
|
|
+ cc = "gcc"
|
|
+ cxx = "g++"
|
|
|
|
- ar = "${toolprefix}ar"
|
|
+ ar = "ar"
|
|
ld = cxx
|
|
- readelf = "${toolprefix}readelf"
|
|
- nm = "${toolprefix}nm"
|
|
+ readelf = "readelf"
|
|
+ nm = "nm"
|
|
|
|
toolchain_args = {
|
|
current_cpu = "arm"
|
|
--
|
|
2.13.2
|
|
|