PKGBUILDs/extra/qt5-webengine/qt5-webengine-fno-delete-null-pointer-checks-2.patch
2016-07-10 03:16:51 +00:00

51 lines
1.7 KiB
Diff

From ba36da6c1f59da7687f6924cc558105dcd1c44dc Mon Sep 17 00:00:00 2001
From: Allan Sandfeld Jensen <allan.jensen@theqtcompany.com>
Date: Fri, 10 Jun 2016 13:26:22 +0200
Subject: [PATCH] Use -fno-delete-null-pointer-checks with gcc 6
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
V8 is not safe for removing null pointer checks. Until it is, we need
to disable optimizations in GCC that assume it is not doing something
wrong.
This patch only enables it for v8, and requires it to be activated
by qtwebengine.
Change-Id: I9da15ecf85719f211ba921a620e9d195eff26178
Task-number: QTBUG-53956
Reviewed-by: Michael Brüning <michael.bruning@qt.io>
---
chromium/v8/build/toolchain.gypi | 7 +++++++
1 file changed, 7 insertions(+)
diff --git a/chromium/v8/build/toolchain.gypi b/chromium/v8/build/toolchain.gypi
index 8a26cc2..2dd4a50 100644
--- a/chromium/v8/build/toolchain.gypi
+++ b/chromium/v8/build/toolchain.gypi
@@ -72,6 +72,10 @@
# Some versions of GCC 4.5 seem to need -fno-strict-aliasing.
'v8_no_strict_aliasing%': 0,
+ # V8 needs support for illegal null this pointers, and must disable
+ # optimizations in GCC 6 that relies on correct behavior.
+ 'v8_no_delete_null_pointer_checks%': 0,
+
# Chrome needs this definition unconditionally. For standalone V8 builds,
# it's handled in build/standalone.gypi.
'want_separate_host_toolset%': 1,
@@ -1066,6 +1070,9 @@
[ 'v8_no_strict_aliasing==1', {
'cflags': [ '-fno-strict-aliasing' ],
}],
+ [ 'v8_no_delete_null_pointer_checks==1', {
+ 'cflags_cc': [ '-fno-delete-null-pointer-checks' ],
+ }],
], # conditions
}],
['OS=="solaris"', {
--
2.8.3