mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
53 lines
2.1 KiB
Diff
53 lines
2.1 KiB
Diff
From 74924b627ddc4093849b581d57c86a68dcea7000 Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Sat, 20 Feb 2021 10:02:34 -0700
|
|
Subject: [PATCH 1/3] use gzip for compression by default
|
|
|
|
---
|
|
man/mkinitcpio.conf.5.adoc | 2 +-
|
|
mkinitcpio | 2 +-
|
|
mkinitcpio.conf | 2 +-
|
|
3 files changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/man/mkinitcpio.conf.5.adoc b/man/mkinitcpio.conf.5.adoc
|
|
index 69bbc6a..ad60b6b 100644
|
|
--- a/man/mkinitcpio.conf.5.adoc
|
|
+++ b/man/mkinitcpio.conf.5.adoc
|
|
@@ -55,7 +55,7 @@ override the main configuration file.
|
|
Defines a program to filter the generated image through. The kernel
|
|
understands the compression formats yielded by the *zstd*(1), *gzip*(1),
|
|
*bzip2*(1), *lz4*(1), *lzop*(1), *lzma*(1), and *xz*(1) compressors. If
|
|
- unspecified, this setting defaults to _zstd_ compression. In order to create
|
|
+ unspecified, this setting defaults to _gzip_ compression. In order to create
|
|
an uncompressed image, define this variable as _cat_.
|
|
+
|
|
It is not hard to realize that a filter such as a _tac_ or _rev_ will cause
|
|
diff --git a/mkinitcpio b/mkinitcpio
|
|
index d6bec2f..c6d5731 100755
|
|
--- a/mkinitcpio
|
|
+++ b/mkinitcpio
|
|
@@ -998,7 +998,7 @@ if [[ -n "$_optgenimg" ]]; then
|
|
die "Unable to write to '%s'" "$_optgenimg"
|
|
fi
|
|
|
|
- _optcompress="${_optcompress:-"${COMPRESSION:-zstd}"}"
|
|
+ _optcompress="${_optcompress:-"${COMPRESSION:-gzip}"}"
|
|
if ! type -P "$_optcompress" >/dev/null; then
|
|
warning "Unable to locate compression method: '%s'" "$_optcompress"
|
|
_optcompress='cat'
|
|
diff --git a/mkinitcpio.conf b/mkinitcpio.conf
|
|
index fc54be6..f728198 100644
|
|
--- a/mkinitcpio.conf
|
|
+++ b/mkinitcpio.conf
|
|
@@ -55,7 +55,7 @@ FILES=()
|
|
HOOKS=(base udev autodetect microcode modconf kms keyboard keymap consolefont block filesystems fsck)
|
|
|
|
# COMPRESSION
|
|
-# Use this to compress the initramfs image. By default, zstd compression
|
|
+# Use this to compress the initramfs image. By default, gzip compression
|
|
# is used. Use 'cat' to create an uncompressed image.
|
|
#COMPRESSION="zstd"
|
|
#COMPRESSION="gzip"
|
|
--
|
|
2.36.1
|
|
|