mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-12-08 23:03:46 +00:00
81 lines
2.4 KiB
Diff
81 lines
2.4 KiB
Diff
diff -wbBur apache_1.3.41/src/support/htdigest.c apache_1.3.41.qwe/src/support/htdigest.c
|
|
--- apache_1.3.41/src/support/htdigest.c 2006-07-12 08:16:05.000000000 +0000
|
|
+++ apache_1.3.41.qwe/src/support/htdigest.c 2009-09-28 08:35:02.000000000 +0000
|
|
@@ -71,7 +71,7 @@
|
|
while ((line[y++] = line[x++]));
|
|
}
|
|
|
|
-static int getline(char *s, int n, FILE *f)
|
|
+static int xgetline(char *s, int n, FILE *f)
|
|
{
|
|
register int i = 0;
|
|
|
|
@@ -158,7 +158,7 @@
|
|
{
|
|
static char line[MAX_STRING_LEN];
|
|
|
|
- while (!(getline(line, MAX_STRING_LEN, source))) {
|
|
+ while (!(xgetline(line, MAX_STRING_LEN, source))) {
|
|
putline(target, line);
|
|
}
|
|
}
|
|
@@ -216,7 +216,7 @@
|
|
ap_cpystrn(realm, argv[2], sizeof(realm));
|
|
|
|
found = 0;
|
|
- while (!(getline(line, MAX_STRING_LEN, f))) {
|
|
+ while (!(xgetline(line, MAX_STRING_LEN, f))) {
|
|
if (found || (line[0] == '#') || (!line[0])) {
|
|
putline(tfp, line);
|
|
continue;
|
|
diff -wbBur apache_1.3.41/src/support/htpasswd.c apache_1.3.41.qwe/src/support/htpasswd.c
|
|
--- apache_1.3.41/src/support/htpasswd.c 2006-07-12 08:16:05.000000000 +0000
|
|
+++ apache_1.3.41.qwe/src/support/htpasswd.c 2009-09-28 08:32:31.000000000 +0000
|
|
@@ -98,7 +98,7 @@
|
|
* Get a line of input from the user, not including any terminating
|
|
* newline.
|
|
*/
|
|
-static int getline(char *s, int n, FILE *f)
|
|
+static int xgetline(char *s, int n, FILE *f)
|
|
{
|
|
register int i = 0;
|
|
|
|
@@ -547,7 +547,7 @@
|
|
char scratch[MAX_STRING_LEN];
|
|
|
|
fpw = fopen(pwfilename, "r");
|
|
- while (! (getline(line, sizeof(line), fpw))) {
|
|
+ while (! (xgetline(line, sizeof(line), fpw))) {
|
|
char *colon;
|
|
|
|
if ((line[0] == '#') || (line[0] == '\0')) {
|
|
diff -wbBur apache_1.3.41/src/support/logresolve.c apache_1.3.41.qwe/src/support/logresolve.c
|
|
--- apache_1.3.41/src/support/logresolve.c 2006-07-12 08:16:05.000000000 +0000
|
|
+++ apache_1.3.41.qwe/src/support/logresolve.c 2009-09-28 08:32:58.000000000 +0000
|
|
@@ -71,7 +71,7 @@
|
|
#endif /* !MPE && !WIN32*/
|
|
|
|
static void cgethost(struct in_addr ipnum, char *string, int check);
|
|
-static int getline(char *s, int n);
|
|
+static int xgetline(char *s, int n);
|
|
static void stats(FILE *output);
|
|
|
|
|
|
@@ -278,7 +278,7 @@
|
|
* gets a line from stdin
|
|
*/
|
|
|
|
-static int getline (char *s, int n)
|
|
+static int xgetline (char *s, int n)
|
|
{
|
|
char *cp;
|
|
|
|
@@ -326,7 +326,7 @@
|
|
for (i = 0; i < MAX_ERR + 2; i++)
|
|
errors[i] = 0;
|
|
|
|
- while (getline(line, MAXLINE)) {
|
|
+ while (xgetline(line, MAXLINE)) {
|
|
if (line[0] == '\0')
|
|
continue;
|
|
entries++;
|