mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-12-08 23:03:46 +00:00
46 lines
1.4 KiB
Diff
46 lines
1.4 KiB
Diff
diff --exclude-from=/home/dang/bin/scripts/diffrc -up -ruN gcolor2-0.4.orig/src/callbacks.c gcolor2-0.4/src/callbacks.c
|
|
--- gcolor2-0.4.orig/src/callbacks.c 2005-07-12 14:06:12.000000000 -0400
|
|
+++ gcolor2-0.4/src/callbacks.c 2007-02-17 19:19:38.000000000 -0500
|
|
@@ -4,6 +4,9 @@
|
|
|
|
#include <gtk/gtk.h>
|
|
#include <stdio.h>
|
|
+#include <string.h>
|
|
+#include <glib.h>
|
|
+#include <glib/gprintf.h>
|
|
|
|
#include "callbacks.h"
|
|
#include "interface.h"
|
|
@@ -172,6 +175,9 @@ void on_copy_color_to_clipboard_activate
|
|
gtk_clipboard_set_text (cb, hex, strlen (hex));
|
|
}
|
|
|
|
+void add_rgb_file (gchar *filename, gchar *type);
|
|
+gchar* get_system_file (void);
|
|
+
|
|
void on_show_system_colors_activate (GtkMenuItem *menuitem, gpointer user_data)
|
|
{
|
|
if (gtk_check_menu_item_get_active (GTK_CHECK_MENU_ITEM (menuitem)))
|
|
@@ -266,6 +272,8 @@ void on_save_button_clicked (GtkButton *
|
|
gtk_widget_destroy (savedialog);
|
|
}
|
|
|
|
+void add_list_color (gchar *spec, gchar *name, gchar *type, gboolean is_new_color);
|
|
+
|
|
void add_color_to_treeview ()
|
|
{
|
|
GtkTreeView *treeview;
|
|
diff --exclude-from=/home/dang/bin/scripts/diffrc -up -ruN gcolor2-0.4.orig/src/main.c gcolor2-0.4/src/main.c
|
|
--- gcolor2-0.4.orig/src/main.c 2005-07-11 10:55:49.000000000 -0400
|
|
+++ gcolor2-0.4/src/main.c 2007-02-17 19:18:23.000000000 -0500
|
|
@@ -4,6 +4,10 @@
|
|
|
|
#include <gtk/gtk.h>
|
|
#include <stdio.h>
|
|
+#include <stdlib.h>
|
|
+#include <string.h>
|
|
+#include <glib.h>
|
|
+#include <glib/gprintf.h>
|
|
|
|
#include "interface.h"
|
|
#include "support.h"
|