PKGBUILDs/community/gnubiff/PKGBUILD
2009-10-09 21:15:33 -05:00

54 lines
1.6 KiB
Bash

# $Id: PKGBUILD 82 2009-07-17 19:56:55Z aaron $
# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
# Maintainer: Tom K <tomk@runbox.com>
# Contributor: Todd Musall <tmusall@gmail.com>
pkgname=gnubiff
pkgver=2.2.11
pkgrel=3
pkgdesc="Mail notification program that checks for mail and displays headers when new mail has arrived"
arch=('i686' 'x86_64')
url="http://gnubiff.sourceforge.net/"
license=("GPL")
depends=('gnome-panel')
makedepends=('perlxml')
conflicts=(gnubiff-gtk)
source=(http://downloads.sourceforge.net/gnubiff/gnubiff-$pkgver.tar.gz)
md5sums=('d9e899f25b1e83081ccd3ac97ee31b8b')
build() {
[ "$GNOMEDIR" = "" ] && GNOMEDIR=/usr
cd $startdir/src/gnubiff-$pkgver
patch -p2 src/support.h <<EOF
diff -wbBur gnubiff-2.2.10/src/support.h gnubiff-2.2.10.my/src/support.h
--- gnubiff-2.2.10/src/support.h 2008-03-22 05:08:51.000000000 +0300
+++ gnubiff-2.2.10.my/src/support.h 2008-04-22 14:21:58.000000000 +0400
@@ -35,6 +35,9 @@
#endif
#include "nls.h"
+#include <stdlib.h>
+#define EXIT_SUCCESS 0
+#define EXIT_FAILURE 1
#include <glib.h>
#include <sstream>
@@ -131,6 +134,9 @@
if ((pos == end) && (last < num))
result << sep << num;
+ if ((pos == end) && (last != num))
+ result << sep << num;
+
// Save new number
inf_bound = last = num;
}
EOF
LDFLAGS="-lgnomeui-2" CFLAGS="-I/usr/include/libgnomeui-2.0" CPPFLAGS="-I/usr/include/libgnomeui-2.0" ./configure --prefix=/usr --with-password --with-password-string --disable-fam
make || return 1
make DESTDIR=$startdir/pkg install || return 1
rm -rf ${pkgdir}/usr/share/info/dir
}