mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-12-08 23:03:46 +00:00
57 lines
1.9 KiB
Diff
57 lines
1.9 KiB
Diff
diff -ru optipng-0.6.2/lib/pngxtern/gif/gifread.c optipng-0.6.2.1/lib/pngxtern/gif/gifread.c
|
|
--- optipng-0.6.2/lib/pngxtern/gif/gifread.c 2006-08-10 20:17:00.000000000 -0400
|
|
+++ optipng-0.6.2.1/lib/pngxtern/gif/gifread.c 2009-02-20 03:11:00.000000000 -0500
|
|
@@ -219,8 +219,7 @@
|
|
**/
|
|
static void GIFReadNextExtension(struct GIFExtension *ext, FILE *stream)
|
|
{
|
|
- unsigned char *ptr;
|
|
- unsigned int len;
|
|
+ unsigned int offset, len;
|
|
int count, label;
|
|
|
|
GIF_FGETC(label, stream);
|
|
@@ -233,7 +232,7 @@
|
|
return;
|
|
}
|
|
|
|
- ptr = ext->Buffer;
|
|
+ offset = 0;
|
|
len = ext->BufferSize;
|
|
for ( ;; )
|
|
{
|
|
@@ -243,10 +242,10 @@
|
|
ext->BufferSize += 1024;
|
|
ext->Buffer = realloc(ext->Buffer, ext->BufferSize);
|
|
}
|
|
- count = ReadDataBlock(ptr, stream);
|
|
+ count = ReadDataBlock(ext->Buffer + offset, stream);
|
|
if (count == 0)
|
|
break;
|
|
- ptr += count;
|
|
+ offset += count;
|
|
len -= count;
|
|
}
|
|
}
|
|
diff -ru optipng-0.6.2/src/optipng.c optipng-0.6.2.1/src/optipng.c
|
|
--- optipng-0.6.2/src/optipng.c 2008-11-09 23:56:00.000000000 -0500
|
|
+++ optipng-0.6.2.1/src/optipng.c 2008-11-11 13:57:00.000000000 -0500
|
|
@@ -542,6 +542,7 @@
|
|
static void
|
|
app_init(void)
|
|
{
|
|
+ setvbuf(stdout, NULL, _IONBF, 0);
|
|
if (options.log_name != NULL)
|
|
{
|
|
/* Open the log file, line-buffered. */
|
|
diff -ru optipng-0.6.2/src/proginfo.h optipng-0.6.2.1/src/proginfo.h
|
|
--- optipng-0.6.2/src/proginfo.h 2008-11-09 23:56:00.000000000 -0500
|
|
+++ optipng-0.6.2.1/src/proginfo.h 2009-02-22 23:38:00.000000000 -0500
|
|
@@ -1,5 +1,5 @@
|
|
#define PROGRAM_NAME "OptiPNG"
|
|
#define PROGRAM_DESCRIPTION "Advanced PNG optimizer"
|
|
-#define PROGRAM_VERSION "0.6.2"
|
|
-#define PROGRAM_COPYRIGHT "Copyright (C) 2001-2008 Cosmin Truta"
|
|
+#define PROGRAM_VERSION "0.6.2.1"
|
|
+#define PROGRAM_COPYRIGHT "Copyright (C) 2001-2009 Cosmin Truta"
|
|
#define PROGRAM_URI "http://optipng.sourceforge.net/"
|