mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-12-08 23:03:46 +00:00
28 lines
1.1 KiB
Diff
28 lines
1.1 KiB
Diff
--- Makefile.in
|
|
+++ Makefile.in
|
|
@@ -208,20 +208,20 @@
|
|
sed -e "s#\@RELPATH\@#$(RELPATH)#" \
|
|
-e "s#\@tls_LIB_FILE\@#$(tls_LIB_FILE)#" \
|
|
< $(srcdir)/pkgIndex.tcl.in > pkgIndex.tcl
|
|
- $(INSTALL_DATA) pkgIndex.tcl $(pkglibdir)
|
|
+ $(INSTALL_DATA) pkgIndex.tcl $(DESTDIR)$(pkglibdir)
|
|
|
|
#========================================================================
|
|
# This rule installs platform-independent files, such as header files.
|
|
#========================================================================
|
|
|
|
install-libraries: libraries
|
|
- $(mkinstalldirs) $(includedir)
|
|
- @echo "Installing header files in $(includedir)"
|
|
+ $(mkinstalldirs) $(DESTDIR)$(includedir)
|
|
+ @echo "Installing header files in $(DESTDIR)$(includedir)"
|
|
@for i in $(GENERIC_HDRS) ; do \
|
|
echo "Installing $$i" ; \
|
|
- $(INSTALL_DATA) $$i $(includedir) ; \
|
|
+ $(INSTALL_DATA) $$i $(DESTDIR)$(includedir) ; \
|
|
done;
|
|
- $(INSTALL_DATA) $(srcdir)/tls.tcl $(pkglibdir)
|
|
+ $(INSTALL_DATA) $(srcdir)/tls.tcl $(DESTDIR)$(pkglibdir)
|
|
|
|
#========================================================================
|
|
# Install documentation. Unix manpages should go in the $(mandir)
|