mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
35 lines
961 B
Diff
35 lines
961 B
Diff
aufs3.1 kbuild patch
|
|
|
|
diff --git a/fs/Kconfig b/fs/Kconfig
|
|
index 9fe0b34..c4311f8 100644
|
|
--- a/fs/Kconfig
|
|
+++ b/fs/Kconfig
|
|
@@ -215,6 +215,7 @@ source "fs/pstore/Kconfig"
|
|
source "fs/sysv/Kconfig"
|
|
source "fs/ufs/Kconfig"
|
|
source "fs/exofs/Kconfig"
|
|
+source "fs/aufs/Kconfig"
|
|
|
|
endif # MISC_FILESYSTEMS
|
|
|
|
diff --git a/fs/Makefile b/fs/Makefile
|
|
index afc1096..5c5ac76 100644
|
|
--- a/fs/Makefile
|
|
+++ b/fs/Makefile
|
|
@@ -123,3 +123,4 @@ obj-$(CONFIG_GFS2_FS) += gfs2/
|
|
obj-$(CONFIG_EXOFS_FS) += exofs/
|
|
obj-$(CONFIG_CEPH_FS) += ceph/
|
|
obj-$(CONFIG_PSTORE) += pstore/
|
|
+obj-$(CONFIG_AUFS_FS) += aufs/
|
|
diff --git a/include/linux/Kbuild b/include/linux/Kbuild
|
|
index 619b565..29f386b 100644
|
|
--- a/include/linux/Kbuild
|
|
+++ b/include/linux/Kbuild
|
|
@@ -65,6 +65,7 @@ header-y += atmppp.h
|
|
header-y += atmsap.h
|
|
header-y += atmsvc.h
|
|
header-y += audit.h
|
|
+header-y += aufs_type.h
|
|
header-y += auto_fs.h
|
|
header-y += auto_fs4.h
|
|
header-y += auxvec.h
|