mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
31 lines
849 B
Diff
31 lines
849 B
Diff
--- a/src/IVtkDraw/IVtkDraw_HighlightAndSelectionPipeline.hxx
|
|
+++ b/src/IVtkDraw/IVtkDraw_HighlightAndSelectionPipeline.hxx
|
|
@@ -23,6 +23,7 @@
|
|
|
|
// prevent disabling some MSVC warning messages by VTK headers
|
|
#include <Standard_WarningsDisable.hxx>
|
|
+#undef AllValues
|
|
#include <vtkActor.h>
|
|
#include <vtkPolyData.h>
|
|
#include <vtkPolyDataMapper.h>
|
|
--- a/src/IVtkVTK/IVtkVTK_ShapeData.hxx
|
|
+++ b/src/IVtkVTK/IVtkVTK_ShapeData.hxx
|
|
@@ -23,6 +23,7 @@
|
|
#include <vtkPolyData.h>
|
|
#include <vtkSmartPointer.h>
|
|
#include <vtkIdTypeArray.h>
|
|
+#include <vtkVersion.h>
|
|
#include <Standard_WarningsRestore.hxx>
|
|
|
|
class vtkIdTypeArray;
|
|
--- a/src/InterfaceGraphic/InterfaceGraphic.hxx
|
|
+++ b/src/InterfaceGraphic/InterfaceGraphic.hxx
|
|
@@ -40,6 +40,8 @@
|
|
#include <X11/Xatom.h>
|
|
#include <GL/glx.h>
|
|
|
|
+#undef AllValues
|
|
+
|
|
#endif
|
|
|
|
#endif // __INTERFACE_GRAPHIC_HXX
|