PKGBUILDs/community/higan/higan-flags.patch
2016-07-23 17:49:27 +00:00

39 lines
1.3 KiB
Diff
Executable file

diff -rupN higan_v097-source.orig/higan/GNUmakefile higan_v097-source/higan/GNUmakefile
--- higan_v097-source.orig/higan/GNUmakefile 2016-01-24 09:21:45.822940200 +0100
+++ higan_v097-source/higan/GNUmakefile 2016-01-24 09:24:03.028722500 +0100
@@ -36,7 +36,7 @@ ifeq ($(platform),windows)
else ifeq ($(platform),macosx)
flags += -march=native
else ifneq ($(filter $(platform),linux bsd),)
- flags += -march=native -fopenmp
+ flags += -fopenmp
link += -fopenmp
link += -Wl,-export-dynamic
link += -lX11 -lXext
diff -rupN higan_v097-source.orig/nall/GNUmakefile higan_v097-source/nall/GNUmakefile
--- higan_v097-source.orig/nall/GNUmakefile 2016-01-24 09:21:46.021749600 +0100
+++ higan_v097-source/nall/GNUmakefile 2016-01-24 09:25:06.347100800 +0100
@@ -40,8 +40,8 @@ cflags := -x c -std=c99
objcflags := -x objective-c -std=c99
cppflags := -x c++ -std=c++14
objcppflags := -x objective-c++ -std=c++14
-flags :=
-link :=
+flags := $(CXXFLAGS)
+link := $(LDFLAGS)
# compiler detection
ifeq ($(compiler),)
@@ -51,9 +51,9 @@ ifeq ($(compiler),)
else ifeq ($(platform),macosx)
compiler := clang++
else ifeq ($(platform),linux)
- compiler := g++-4.9
+ compiler := g++
else ifeq ($(platform),bsd)
- compiler := g++49
+ compiler := g++
else
compiler := g++
endif