mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
93 lines
2.7 KiB
Diff
Executable file
93 lines
2.7 KiB
Diff
Executable file
From bfbdf60074337d435f84bb3947c7ed4738405945 Mon Sep 17 00:00:00 2001
|
|
From: ponce <matteo.bernardini@gmail.com>
|
|
Date: Sat, 4 May 2013 08:44:53 +0200
|
|
Subject: [PATCH 1/2] block: cgroups, kconfig, build bits for BFQ-v6-3.9
|
|
|
|
Update Kconfig.iosched and do the related Makefile changes to include
|
|
kernel configuration options for BFQ. Also add the bfqio controller
|
|
to the cgroups subsystem.
|
|
---
|
|
block/Kconfig.iosched | 25 +++++++++++++++++++++++++
|
|
block/Makefile | 1 +
|
|
include/linux/cgroup_subsys.h | 6 ++++++
|
|
3 files changed, 32 insertions(+)
|
|
|
|
diff --git a/block/Kconfig.iosched b/block/Kconfig.iosched
|
|
index 421bef9..695e064 100644
|
|
--- a/block/Kconfig.iosched
|
|
+++ b/block/Kconfig.iosched
|
|
@@ -39,6 +39,27 @@ config CFQ_GROUP_IOSCHED
|
|
---help---
|
|
Enable group IO scheduling in CFQ.
|
|
|
|
+config IOSCHED_BFQ
|
|
+ tristate "BFQ I/O scheduler"
|
|
+ default n
|
|
+ ---help---
|
|
+ The BFQ I/O scheduler tries to distribute bandwidth among
|
|
+ all processes according to their weights.
|
|
+ It aims at distributing the bandwidth as desired, independently of
|
|
+ the disk parameters and with any workload. It also tries to
|
|
+ guarantee low latency to interactive and soft real-time
|
|
+ applications. If compiled built-in (saying Y here), BFQ can
|
|
+ be configured to support hierarchical scheduling.
|
|
+
|
|
+config CGROUP_BFQIO
|
|
+ bool "BFQ hierarchical scheduling support"
|
|
+ depends on CGROUPS && IOSCHED_BFQ=y
|
|
+ default n
|
|
+ ---help---
|
|
+ Enable hierarchical scheduling in BFQ, using the cgroups
|
|
+ filesystem interface. The name of the subsystem will be
|
|
+ bfqio.
|
|
+
|
|
choice
|
|
prompt "Default I/O scheduler"
|
|
default DEFAULT_CFQ
|
|
@@ -52,6 +73,9 @@ choice
|
|
config DEFAULT_CFQ
|
|
bool "CFQ" if IOSCHED_CFQ=y
|
|
|
|
+ config DEFAULT_BFQ
|
|
+ bool "BFQ" if IOSCHED_BFQ=y
|
|
+
|
|
config DEFAULT_NOOP
|
|
bool "No-op"
|
|
|
|
@@ -61,6 +85,7 @@ config DEFAULT_IOSCHED
|
|
string
|
|
default "deadline" if DEFAULT_DEADLINE
|
|
default "cfq" if DEFAULT_CFQ
|
|
+ default "bfq" if DEFAULT_BFQ
|
|
default "noop" if DEFAULT_NOOP
|
|
|
|
endmenu
|
|
diff --git a/block/Makefile b/block/Makefile
|
|
index 39b76ba..c0d20fa 100644
|
|
--- a/block/Makefile
|
|
+++ b/block/Makefile
|
|
@@ -15,6 +15,7 @@ obj-$(CONFIG_BLK_DEV_THROTTLING) += blk-throttle.o
|
|
obj-$(CONFIG_IOSCHED_NOOP) += noop-iosched.o
|
|
obj-$(CONFIG_IOSCHED_DEADLINE) += deadline-iosched.o
|
|
obj-$(CONFIG_IOSCHED_CFQ) += cfq-iosched.o
|
|
+obj-$(CONFIG_IOSCHED_BFQ) += bfq-iosched.o
|
|
|
|
obj-$(CONFIG_BLOCK_COMPAT) += compat_ioctl.o
|
|
obj-$(CONFIG_BLK_DEV_INTEGRITY) += blk-integrity.o
|
|
diff --git a/include/linux/cgroup_subsys.h b/include/linux/cgroup_subsys.h
|
|
index f204a7a..b999bfa 100644
|
|
--- a/include/linux/cgroup_subsys.h
|
|
+++ b/include/linux/cgroup_subsys.h
|
|
@@ -78,3 +78,9 @@ SUBSYS(hugetlb)
|
|
#endif
|
|
|
|
/* */
|
|
+
|
|
+#ifdef CONFIG_CGROUP_BFQIO
|
|
+SUBSYS(bfqio)
|
|
+#endif
|
|
+
|
|
+/* */
|
|
--
|
|
1.8.2
|
|
|