mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
26 lines
1 KiB
Diff
26 lines
1 KiB
Diff
diff --git a/elf/rtld.c b/elf/rtld.c
|
|
index 9a560b3..201c9cf 100644
|
|
--- a/elf/rtld.c
|
|
+++ b/elf/rtld.c
|
|
@@ -2168,6 +2168,10 @@ ERROR: ld.so: object '%s' cannot be loaded as audit interface: %s; ignored.\n",
|
|
we need it in the memory handling later. */
|
|
GLRO(dl_initial_searchlist) = *GL(dl_ns)[LM_ID_BASE]._ns_main_searchlist;
|
|
|
|
+ /* Remember the last search directory added at startup, now that
|
|
+ malloc will no longer be the one from dl-minimal.c. */
|
|
+ GLRO(dl_init_all_dirs) = GL(dl_all_dirs);
|
|
+
|
|
if (prelinked)
|
|
{
|
|
if (main_map->l_info [ADDRIDX (DT_GNU_CONFLICT)] != NULL)
|
|
@@ -2288,10 +2292,6 @@ ERROR: ld.so: object '%s' cannot be loaded as audit interface: %s; ignored.\n",
|
|
lossage);
|
|
}
|
|
|
|
- /* Remember the last search directory added at startup, now that
|
|
- malloc will no longer be the one from dl-minimal.c. */
|
|
- GLRO(dl_init_all_dirs) = GL(dl_all_dirs);
|
|
-
|
|
if (! prelinked && rtld_multiple_ref)
|
|
{
|
|
/* There was an explicit ref to the dynamic linker as a shared lib.
|