PKGBUILDs/extra/chromium/iwyu-add-stdint.h-for-uint32_t-in-cc.patch
2023-05-09 12:44:29 +00:00

28 lines
929 B
Diff

From e80fc92c8ac9f727486bddeb964206fe7a52fac5 Mon Sep 17 00:00:00 2001
From: Stephan Hartmann <stha09@googlemail.com>
Date: Mon, 10 Apr 2023 15:44:41 +0000
Subject: [PATCH] IWYU: add stdint.h for uint32_t in cc::TargetProperty
Change-Id: If8b3a9cdf0d310391aeed3abf303e2ea054697b1
Bug: 957519
Reviewed-on: https://chromium-review.googlesource.com/c/chromium/src/+/4406545
Reviewed-by: Stefan Zager <szager@chromium.org>
Commit-Queue: Stephan Hartmann <stha09@googlemail.com>
Cr-Commit-Position: refs/heads/main@{#1128159}
---
cc/trees/target_property.cc | 2 ++
1 file changed, 2 insertions(+)
diff --git a/cc/trees/target_property.cc b/cc/trees/target_property.cc
index f6e873a01a1..7d73467a92f 100644
--- a/cc/trees/target_property.cc
+++ b/cc/trees/target_property.cc
@@ -4,6 +4,8 @@
#include "cc/trees/target_property.h"
+#include <stdint.h>
+
#include "ui/gfx/animation/keyframe/target_property.h"
namespace cc {