mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
51 lines
1.6 KiB
Diff
51 lines
1.6 KiB
Diff
From f8d65c61edd2ba483f1f6167c8a5fe5ad53254ea Mon Sep 17 00:00:00 2001
|
|
From: Stephan Hartmann <stha09@googlemail.com>
|
|
Date: Wed, 5 Apr 2023 18:53:56 +0200
|
|
Subject: [PATCH] IWYU: add stdint.h for various integer types
|
|
|
|
Bug: chromium:957519
|
|
Change-Id: If28a50f5b1c68fffd1ba546dea18b4d906a42bbf
|
|
Reviewed-on: https://chromium-review.googlesource.com/c/openscreen/+/4403253
|
|
Reviewed-by: Mark Foltz <mfoltz@chromium.org>
|
|
Commit-Queue: Mark Foltz <mfoltz@chromium.org>
|
|
---
|
|
AUTHORS | 1 +
|
|
discovery/dnssd/public/dns_sd_txt_record.h | 2 ++
|
|
util/base64.h | 2 ++
|
|
3 files changed, 5 insertions(+)
|
|
|
|
diff --git a/AUTHORS b/AUTHORS
|
|
index 768523fc..4e9e5667 100644
|
|
--- a/AUTHORS
|
|
+++ b/AUTHORS
|
|
@@ -5,3 +5,4 @@ Peter Thatcher <pthatcher@chromium.org>
|
|
Jordan Bayles <jophba@chromium.org>
|
|
Max Yakimakha <yakimakha@chromium.org>
|
|
Ryan Keane <rwkeane@google.com>
|
|
+Stephan Hartmann <stha09@googlemail.com>
|
|
diff --git a/discovery/dnssd/public/dns_sd_txt_record.h b/discovery/dnssd/public/dns_sd_txt_record.h
|
|
index edf2c782..c9b5c436 100644
|
|
--- a/discovery/dnssd/public/dns_sd_txt_record.h
|
|
+++ b/discovery/dnssd/public/dns_sd_txt_record.h
|
|
@@ -5,6 +5,8 @@
|
|
#ifndef DISCOVERY_DNSSD_PUBLIC_DNS_SD_TXT_RECORD_H_
|
|
#define DISCOVERY_DNSSD_PUBLIC_DNS_SD_TXT_RECORD_H_
|
|
|
|
+#include <stdint.h>
|
|
+
|
|
#include <functional>
|
|
#include <map>
|
|
#include <set>
|
|
diff --git a/util/base64.h b/util/base64.h
|
|
index a7af9eca..86261936 100644
|
|
--- a/util/base64.h
|
|
+++ b/util/base64.h
|
|
@@ -5,6 +5,8 @@
|
|
#ifndef UTIL_BASE64_H_
|
|
#define UTIL_BASE64_H_
|
|
|
|
+#include <stdint.h>
|
|
+
|
|
#include <string>
|
|
#include <vector>
|
|
|