mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
33 lines
1.1 KiB
Diff
33 lines
1.1 KiB
Diff
From e9fa04548195495c53ed7d13a7f6028f60b24fde Mon Sep 17 00:00:00 2001
|
|
From: Marc Zyngier <Marc.Zyngier@arm.com>
|
|
Date: Sat, 1 Jul 2017 15:16:34 +0100
|
|
Subject: [PATCH 2/8] ARM64: dts: marvell: armada37xx: Fix GIC maintenance
|
|
interrupt
|
|
|
|
The GIC-500 integrated in the Armada-37xx SoCs is compliant with
|
|
the GICv3 architecture, and thus provides a maintenance interrupt
|
|
that is required for hypervisors to function correctly.
|
|
|
|
With the interrupt provided in the DT, KVM now works as it should.
|
|
Tested on an Espressobin system.
|
|
|
|
Signed-off-by: Marc Zyngier <marc.zyngier@arm.com>
|
|
---
|
|
arch/arm64/boot/dts/marvell/armada-37xx.dtsi | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
|
index bc179efb10ef..592e95e5f633 100644
|
|
--- a/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
|
+++ b/arch/arm64/boot/dts/marvell/armada-37xx.dtsi
|
|
@@ -312,6 +312,7 @@
|
|
interrupt-controller;
|
|
reg = <0x1d00000 0x10000>, /* GICD */
|
|
<0x1d40000 0x40000>; /* GICR */
|
|
+ interrupts = <GIC_PPI 9 IRQ_TYPE_LEVEL_HIGH>;
|
|
};
|
|
};
|
|
|
|
--
|
|
2.13.2
|
|
|