PKGBUILDs/extra/spice/alarm.patch
2014-07-07 11:50:45 +00:00

27 lines
1 KiB
Diff

diff -urN a/client/red_pixmap.h b/client/red_pixmap.h
--- a/client/red_pixmap.h 2014-05-14 05:14:34.000000000 -0600
+++ b/client/red_pixmap.h 2014-07-07 05:29:00.121233414 -0600
@@ -46,8 +46,6 @@
spice_printerr("equal fails at (+%d+%d) +%d+%d:%d in %dx%d",
rect.left, rect.top, x-rect.left, y-rect.top, i,
_width-rect.left, _height-rect.top);
- if (getenv("DIFFBP"))
- SPICE_BREAKPOINT();
return false;
}
}
diff -urN a/client/utils.h b/client/utils.h
--- a/client/utils.h 2014-05-14 05:14:34.000000000 -0600
+++ b/client/utils.h 2014-07-07 05:29:16.866177393 -0600
@@ -50,10 +50,6 @@
throw Exception(exption_string, err); \
}
-#define SPICE_BREAKPOINT() do{ \
- __asm__ __volatile__ ("int $03"); \
-}while(0)
-
template <class T>
class AutoRef {
public: