mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
26 lines
1.1 KiB
Diff
26 lines
1.1 KiB
Diff
From b06428ed9945f818095f1b8e725850b2d3b8551b Mon Sep 17 00:00:00 2001
|
|
From: graysky <graysky@archlinux.us>
|
|
Date: Thu, 10 Mar 2022 17:36:13 -0500
|
|
Subject: [PATCH] mcpu=cortex-xxx application to ffmpeg
|
|
|
|
Get build system to patch ffmpeg source removing the -march= flag
|
|
|
|
---
|
|
cmake/modules/FindFFMPEG.cmake | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/cmake/modules/FindFFMPEG.cmake b/cmake/modules/FindFFMPEG.cmake
|
|
index 6b957f760e..296ed09968 100644
|
|
--- a/cmake/modules/FindFFMPEG.cmake
|
|
+++ b/cmake/modules/FindFFMPEG.cmake
|
|
@@ -97,6 +97,7 @@ macro(buildFFMPEG)
|
|
${CMAKE_SOURCE_DIR}/cmake/modules/FindGnuTLS.cmake
|
|
<SOURCE_DIR> &&
|
|
patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0001-rpi-Add-hevc-acceleration.patch &&
|
|
+ patch -p1 < ${CMAKE_SOURCE_DIR}/tools/depends/target/ffmpeg/0002-use-mcpu-avoiding-march-and-mtune.patch &&
|
|
echo "########################################## patched ffmpeg ##############################")
|
|
|
|
BUILD_DEP_TARGET()
|
|
--
|
|
2.35.1
|
|
|