PKGBUILDs/extra/icecast/icecast-2.3.1-nocurlpassword.patch
2009-10-09 21:23:22 -05:00

25 lines
908 B
Diff

--- ./src/auth_url.c.orig 2007-04-17 22:48:11.000000000 +1000
+++ ./src/auth_url.c 2007-04-17 22:48:59.000000000 +1000
@@ -112,14 +112,6 @@
}
-/* make sure that prompting at the console does not occur */
-static int my_getpass(void *client, char *prompt, char *buffer, int buflen)
-{
- buffer[0] = '\0';
- return 0;
-}
-
-
static int handle_returned_header (void *ptr, size_t size, size_t nmemb, void *stream)
{
auth_client *auth_user = stream;
@@ -518,7 +510,6 @@
curl_easy_setopt (url_info->handle, CURLOPT_WRITEDATA, url_info->handle);
curl_easy_setopt (url_info->handle, CURLOPT_NOSIGNAL, 1L);
curl_easy_setopt (url_info->handle, CURLOPT_TIMEOUT, 15L);
- curl_easy_setopt (url_info->handle, CURLOPT_PASSWDFUNCTION, my_getpass);
curl_easy_setopt (url_info->handle, CURLOPT_ERRORBUFFER, &url_info->errormsg[0]);
if (url_info->username && url_info->password)