mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
18 lines
631 B
Diff
18 lines
631 B
Diff
--- liblrdf-0.4.0.orig/src/lrdf_md5.h
|
|
+++ liblrdf-0.4.0/src/lrdf_md5.h
|
|
@@ -32,6 +32,15 @@
|
|
#ifndef __MD5_H__
|
|
#define __MD5_H__
|
|
|
|
+/* Change function names to prevent symbol conflicts */
|
|
+#define md5_init _lrdf_md5_init
|
|
+#define md5_buffer _lrdf_md5_buffer
|
|
+#define md5_sig_from_string _lrdf_md5_sig_from_string
|
|
+#define md5_finish _lrdf_md5_finish
|
|
+#define md5_process _lrdf_md5_process
|
|
+#define md5_sig_to_string _lrdf_md5_sig_to_string
|
|
+#define md5_get_result _lrdf_md5_get_result
|
|
+
|
|
/*
|
|
* Size of a standard MD5 signature in bytes. This definition is for
|
|
* external programs only. The MD5 routines themselves reference the
|