PKGBUILDs/extra/pdksh/pdksh-5.2.14.patch
2009-10-09 21:23:22 -05:00

26 lines
977 B
Diff

diff -ru pdksh-5.2.14/siglist.sh pdksh-5.2.14.arch/siglist.sh
--- pdksh-5.2.14/siglist.sh 1996-09-18 12:52:41.000000000 -0400
+++ pdksh-5.2.14.arch/siglist.sh 2004-09-06 08:17:15.000000000 -0400
@@ -11,19 +11,18 @@
out=tmpo$$.c
ecode=1
trapsigs='0 1 2 13 15'
-trap 'rm -f $in $out; trap 0; exit $ecode' $trapsigs
+trap 'rm -f $in $out; exit $ecode' $trapsigs
CPP="${1-cc -E}"
# The trap here to make up for a bug in bash (1.14.3(1)) that calls the trap
-(trap $trapsigs;
- echo '#include "sh.h"';
+(echo '#include "sh.h"';
echo ' { QwErTy SIGNALS , "DUMMY" , "hook for number of signals" },';
sed -e '/^[ ]*#/d' -e 's/^[ ]*\([^ ][^ ]*\)[ ][ ]*\(.*[^ ]\)[ ]*$/#ifdef SIG\1\
{ QwErTy SIG\1 , "\1", "\2" },\
#endif/') > $in
$CPP $in > $out
-sed -n 's/{ QwErTy/{/p' < $out | awk '{print NR, $0}' | sort +2n +0n |
+sed -n 's/{ QwErTy/{/p' < $out | awk '{print NR, $0}' | sort -g --key=3 |
sed 's/^[0-9]* //' |
awk 'BEGIN { last=0; nsigs=0; }
{