mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
13 lines
295 B
Diff
13 lines
295 B
Diff
--- unix/unix.cpp
|
|
+++ unix/unix.cpp
|
|
@@ -1162,8 +1162,8 @@
|
|
{
|
|
*drive = 0;
|
|
|
|
- char *slash = strrchr(path, SLASH_CHAR);
|
|
- char *dot = strrchr(path, '.');
|
|
+ char *slash = strrchr((char *)path, SLASH_CHAR);
|
|
+ char *dot = strrchr((char *)path, '.');
|
|
|
|
if (dot && slash && dot < slash)
|
|
{
|