PKGBUILDs/extra/xf86-input-dmc/git-4e3c2643.patch
2009-10-09 21:23:22 -05:00

138 lines
5.7 KiB
Diff

diff -ruN -x .gitignore xf86-input-dmc-a588412e30c6e1d23817c8a559e4e3b583f980e2/Makefile.am xf86-input-dmc-4e3c26430cd2fe9510c252a48605f4a1b1550d39/Makefile.am
--- xf86-input-dmc-a588412e30c6e1d23817c8a559e4e3b583f980e2/Makefile.am 2008-03-20 19:17:39.000000000 +0000
+++ xf86-input-dmc-4e3c26430cd2fe9510c252a48605f4a1b1550d39/Makefile.am 2009-02-02 20:44:11.000000000 +0000
@@ -20,14 +20,12 @@
AUTOMAKE_OPTIONS = foreign
SUBDIRS = src man
-
-EXTRA_DIST=ChangeLog autogen.sh
-
-CLEANFILES=ChangeLog
+EXTRA_DIST = ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
.PHONY: ChangeLog
ChangeLog:
- (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+ $(CHANGELOG_CMD)
dist-hook: ChangeLog
diff -ruN -x .gitignore xf86-input-dmc-a588412e30c6e1d23817c8a559e4e3b583f980e2/README xf86-input-dmc-4e3c26430cd2fe9510c252a48605f4a1b1550d39/README
--- xf86-input-dmc-a588412e30c6e1d23817c8a559e4e3b583f980e2/README 1970-01-01 00:00:00.000000000 +0000
+++ xf86-input-dmc-4e3c26430cd2fe9510c252a48605f4a1b1550d39/README 2009-02-02 20:44:11.000000000 +0000
@@ -0,0 +1,20 @@
+xf86-input-dmc - DMC input driver for the Xorg X server
+
+Please submit bugs & patches to the Xorg bugzilla:
+
+ https://bugs.freedesktop.org/enter_bug.cgi?product=xorg
+
+All questions regarding this software should be directed at the
+Xorg mailing list:
+
+ http://lists.freedesktop.org/mailman/listinfo/xorg
+
+The master development code repository can be found at:
+
+ git://anongit.freedesktop.org/git/xorg/driver/xf86-input-dmc
+
+ http://cgit.freedesktop.org/xorg/driver/xf86-input-dmc
+
+For more information on the git code manager, see:
+
+ http://wiki.x.org/wiki/GitPage
diff -ruN -x .gitignore xf86-input-dmc-a588412e30c6e1d23817c8a559e4e3b583f980e2/configure.ac xf86-input-dmc-4e3c26430cd2fe9510c252a48605f4a1b1550d39/configure.ac
--- xf86-input-dmc-a588412e30c6e1d23817c8a559e4e3b583f980e2/configure.ac 2008-03-20 19:17:39.000000000 +0000
+++ xf86-input-dmc-4e3c26430cd2fe9510c252a48605f4a1b1550d39/configure.ac 2009-02-02 20:44:11.000000000 +0000
@@ -32,15 +32,16 @@
AM_MAINTAINER_MODE
-DRIVER_NAME=dmc
-AC_SUBST([DRIVER_NAME])
-
+# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.2)
AM_CONFIG_HEADER([config.h])
# Checks for programs.
AC_DISABLE_STATIC
AC_PROG_LIBTOOL
AC_PROG_CC
+XORG_CWARNFLAGS
AH_TOP([#include "xorg-server.h"])
@@ -77,16 +78,18 @@
# Checks for pkg-config packages
PKG_CHECK_MODULES(XORG, [xorg-server >= 1.0.99.901] xproto $REQUIRED_MODULES)
sdkdir=$(pkg-config --variable=sdkdir xorg-server)
-
-CFLAGS="$CFLAGS $XORG_CFLAGS "' -I$(top_srcdir)/src'
-AC_SUBST([CFLAGS])
+XORG_CFLAGS="$CWARNFLAGS $XORG_CFLAGS"
# Checks for libraries.
# Checks for header files.
AC_HEADER_STDC
+DRIVER_NAME=dmc
+AC_SUBST([DRIVER_NAME])
+
XORG_MANPAGE_SECTIONS
XORG_RELEASE_VERSION
+XORG_CHANGELOG
AC_OUTPUT([Makefile src/Makefile man/Makefile])
diff -ruN -x .gitignore xf86-input-dmc-a588412e30c6e1d23817c8a559e4e3b583f980e2/man/dmc.man xf86-input-dmc-4e3c26430cd2fe9510c252a48605f4a1b1550d39/man/dmc.man
--- xf86-input-dmc-a588412e30c6e1d23817c8a559e4e3b583f980e2/man/dmc.man 2008-03-20 19:17:39.000000000 +0000
+++ xf86-input-dmc-4e3c26430cd2fe9510c252a48605f4a1b1550d39/man/dmc.man 2009-02-02 20:44:11.000000000 +0000
@@ -33,6 +33,6 @@
.PP
Config details...
.SH "SEE ALSO"
-__xservername__(__appmansuffix__), __xconfigfile__(__filemansuffix__), xorgconfig(__appmansuffix__), Xserver(__appmansuffix__), X(__miscmansuffix__).
+__xservername__(__appmansuffix__), __xconfigfile__(__filemansuffix__), Xserver(__appmansuffix__), X(__miscmansuffix__).
.SH AUTHORS
Authors include...
diff -ruN -x .gitignore xf86-input-dmc-a588412e30c6e1d23817c8a559e4e3b583f980e2/src/Makefile.am xf86-input-dmc-4e3c26430cd2fe9510c252a48605f4a1b1550d39/src/Makefile.am
--- xf86-input-dmc-a588412e30c6e1d23817c8a559e4e3b583f980e2/src/Makefile.am 2008-03-20 19:17:39.000000000 +0000
+++ xf86-input-dmc-4e3c26430cd2fe9510c252a48605f4a1b1550d39/src/Makefile.am 2009-02-02 20:44:11.000000000 +0000
@@ -24,6 +24,8 @@
# -avoid-version prevents gratuitous .0.0.0 version numbers on the end
# _ladir passes a dummy rpath to libtool so the thing will actually link
# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
+AM_CFLAGS = $(XORG_CFLAGS)
+
@DRIVER_NAME@_drv_la_LTLIBRARIES = @DRIVER_NAME@_drv.la
@DRIVER_NAME@_drv_la_LDFLAGS = -module -avoid-version
@DRIVER_NAME@_drv_ladir = @inputdir@
diff -ruN -x .gitignore xf86-input-dmc-a588412e30c6e1d23817c8a559e4e3b583f980e2/src/xf86DMC.c xf86-input-dmc-4e3c26430cd2fe9510c252a48605f4a1b1550d39/src/xf86DMC.c
--- xf86-input-dmc-a588412e30c6e1d23817c8a559e4e3b583f980e2/src/xf86DMC.c 2008-03-20 19:17:39.000000000 +0000
+++ xf86-input-dmc-4e3c26430cd2fe9510c252a48605f4a1b1550d39/src/xf86DMC.c 2009-02-02 20:44:11.000000000 +0000
@@ -106,7 +106,9 @@
"xf86CollectInputOptions",
"xf86ErrorFVerb",
"xf86FindOptionValue",
+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) < 3
"xf86GetMotionEvents",
+#endif
"xf86GetVerbosity",
"xf86MotionHistoryAllocate",
"xf86NameCmp",
@@ -301,7 +303,10 @@
* Device reports motions on 2 axes in absolute coordinates.
* Axes min and max values are reported in raw coordinates.
*/
- if (InitValuatorClassDeviceStruct (dev, 2, xf86GetMotionEvents,
+ if (InitValuatorClassDeviceStruct (dev, 2,
+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) < 3
+ xf86GetMotionEvents,
+#endif
pInfo->history_size, Absolute) == FALSE)
{
ErrorF ("Unable to allocate DMC ValuatorClassDeviceStruct\n");