mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
54 lines
1.9 KiB
Diff
54 lines
1.9 KiB
Diff
From a94fa896cc92d5e0678376cf5aa8b64af0899732 Mon Sep 17 00:00:00 2001
|
|
From: Nikita Popov <nikita.ppv@gmail.com>
|
|
Date: Tue, 4 Feb 2020 20:35:50 +0100
|
|
Subject: [PATCH 4/5] Fix timeTraceProfilerInitialize for LLVM 10
|
|
|
|
---
|
|
src/rustllvm/PassWrapper.cpp | 6 +++++-
|
|
1 file changed, 5 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/src/rustllvm/PassWrapper.cpp b/src/rustllvm/PassWrapper.cpp
|
|
index 90d24d20737db..9e8614e3b6d34 100644
|
|
--- a/src/rustllvm/PassWrapper.cpp
|
|
+++ b/src/rustllvm/PassWrapper.cpp
|
|
@@ -67,7 +67,11 @@ extern "C" void LLVMInitializePasses() {
|
|
}
|
|
|
|
extern "C" void LLVMTimeTraceProfilerInitialize() {
|
|
-#if LLVM_VERSION_GE(9, 0)
|
|
+#if LLVM_VERSION_GE(10, 0)
|
|
+ timeTraceProfilerInitialize(
|
|
+ /* TimeTraceGranularity */ 0,
|
|
+ /* ProcName */ "rustc");
|
|
+#elif LLVM_VERSION_GE(9, 0)
|
|
timeTraceProfilerInitialize();
|
|
#endif
|
|
}
|
|
|
|
From 497f879b1e24c369362bcd821959ffabc50a8a31 Mon Sep 17 00:00:00 2001
|
|
From: Nikita Popov <nikita.ppv@gmail.com>
|
|
Date: Mon, 2 Mar 2020 22:37:55 +0100
|
|
Subject: [PATCH 5/5] Update CreateMemSet() usage for LLVM 10
|
|
|
|
---
|
|
src/rustllvm/RustWrapper.cpp | 5 +++++
|
|
1 file changed, 5 insertions(+)
|
|
|
|
diff --git a/src/rustllvm/RustWrapper.cpp b/src/rustllvm/RustWrapper.cpp
|
|
index 25cfee3373dc4..799adb418822d 100644
|
|
--- a/src/rustllvm/RustWrapper.cpp
|
|
+++ b/src/rustllvm/RustWrapper.cpp
|
|
@@ -1333,8 +1333,13 @@ extern "C" LLVMValueRef LLVMRustBuildMemSet(LLVMBuilderRef B,
|
|
LLVMValueRef Dst, unsigned DstAlign,
|
|
LLVMValueRef Val,
|
|
LLVMValueRef Size, bool IsVolatile) {
|
|
+#if LLVM_VERSION_GE(10, 0)
|
|
+ return wrap(unwrap(B)->CreateMemSet(
|
|
+ unwrap(Dst), unwrap(Val), unwrap(Size), MaybeAlign(DstAlign), IsVolatile));
|
|
+#else
|
|
return wrap(unwrap(B)->CreateMemSet(
|
|
unwrap(Dst), unwrap(Val), unwrap(Size), DstAlign, IsVolatile));
|
|
+#endif
|
|
}
|
|
|
|
extern "C" LLVMValueRef
|