mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
26 lines
1.2 KiB
Diff
26 lines
1.2 KiB
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: "Jan Alexander Steffens (heftig)" <heftig@archlinux.org>
|
|
Date: Thu, 13 Jul 2023 21:16:53 +0200
|
|
Subject: [PATCH] bootstrap: Change bash-completion dir
|
|
|
|
---
|
|
src/bootstrap/src/core/build_steps/dist.rs | 6 +++++-
|
|
1 file changed, 5 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/src/bootstrap/src/core/build_steps/dist.rs b/src/bootstrap/src/core/build_steps/dist.rs
|
|
index 5184d384e6b8..d54e599f474b 100644
|
|
--- a/src/bootstrap/src/core/build_steps/dist.rs
|
|
+++ b/src/bootstrap/src/core/build_steps/dist.rs
|
|
@@ -1071,7 +1071,11 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
|
|
|
tarball.add_file(&cargo, "bin", 0o755);
|
|
tarball.add_file(etc.join("_cargo"), "share/zsh/site-functions", 0o644);
|
|
- tarball.add_renamed_file(etc.join("cargo.bashcomp.sh"), "etc/bash_completion.d", "cargo");
|
|
+ tarball.add_renamed_file(
|
|
+ etc.join("cargo.bashcomp.sh"),
|
|
+ "share/bash-completion/completions",
|
|
+ "cargo",
|
|
+ );
|
|
tarball.add_dir(etc.join("man"), "share/man/man1");
|
|
tarball.add_legal_and_readme_to("share/doc/cargo");
|
|
|