mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
56 lines
1.6 KiB
Diff
56 lines
1.6 KiB
Diff
diff --git i/cpp/CMakeLists.txt w/cpp/CMakeLists.txt
|
|
index 57261a63..83440382 100644
|
|
--- i/cpp/CMakeLists.txt
|
|
+++ w/cpp/CMakeLists.txt
|
|
@@ -18,7 +18,7 @@ cmake_minimum_required (VERSION 3.11)
|
|
|
|
# Pick the C++ standard to compile with.
|
|
# Abseil currently supports C++11, C++14, and C++17.
|
|
-set(CMAKE_CXX_STANDARD 11)
|
|
+set(CMAKE_CXX_STANDARD 17)
|
|
set(CMAKE_CXX_STANDARD_REQUIRED ON)
|
|
|
|
project (libphonenumber)
|
|
@@ -126,6 +126,8 @@ if (${USE_BOOST} STREQUAL "OFF" AND ${USE_STDMUTEX} STREQUAL "OFF")
|
|
find_package (Threads)
|
|
endif()
|
|
|
|
+find_package (absl REQUIRED)
|
|
+
|
|
find_or_build_gtest ()
|
|
|
|
if (${USE_RE2} STREQUAL "ON")
|
|
diff --git i/tools/cpp/CMakeLists.txt w/tools/cpp/CMakeLists.txt
|
|
index b0941656..58a9b3ba 100644
|
|
--- i/tools/cpp/CMakeLists.txt
|
|
+++ w/tools/cpp/CMakeLists.txt
|
|
@@ -26,29 +26,6 @@ project (generate_geocoding_data)
|
|
# Helper functions dealing with finding libraries and programs this library
|
|
# depends on.
|
|
include (gtest.cmake)
|
|
-include (FetchContent)
|
|
-
|
|
-# Downloading the abseil sources.
|
|
-FetchContent_Declare(
|
|
- abseil-cpp
|
|
- GIT_REPOSITORY https://github.com/abseil/abseil-cpp.git
|
|
- GIT_TAG origin/master
|
|
-)
|
|
-
|
|
-# Building the abseil binaries
|
|
-FetchContent_GetProperties(abseil-cpp)
|
|
-if (NOT abseil-cpp_POPULATED)
|
|
- FetchContent_Populate(abseil-cpp)
|
|
-endif ()
|
|
-
|
|
-if (NOT abseil-cpp_POPULATED)
|
|
- message (FATAL_ERROR "Could not build abseil-cpp binaries.")
|
|
-endif ()
|
|
-
|
|
-# Safeguarding against any potential link errors as mentioned in
|
|
-# https://github.com/abseil/abseil-cpp/issues/225
|
|
-set(CMAKE_POSITION_INDEPENDENT_CODE TRUE)
|
|
-add_subdirectory(${abseil-cpp_SOURCE_DIR} ${abseil-cpp_BINARY_DIR})
|
|
|
|
find_or_build_gtest ()
|
|
set (
|