mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
40 lines
1.2 KiB
Diff
40 lines
1.2 KiB
Diff
From bf66fef1df9fa1012849e01a888d359622816221 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?J=C3=A1n=20Tomko?= <jtomko@redhat.com>
|
|
Date: Mon, 13 Aug 2018 13:39:25 +0200
|
|
Subject: [PATCH 07/16] Revert "tests: also skip qemuagenttest with old
|
|
jansson"
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
This reverts commit c31146685f5c8558ff88d52d03a68533c9220feb.
|
|
|
|
Jansson cannot parse QEMU's quirky JSON.
|
|
Revert back to yajl.
|
|
|
|
https://bugzilla.redhat.com/show_bug.cgi?id=1614569
|
|
|
|
Signed-off-by: Ján Tomko <jtomko@redhat.com>
|
|
Reviewed-by: Daniel P. Berrangé <berrange@redhat.com>
|
|
---
|
|
tests/qemuagenttest.c | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/tests/qemuagenttest.c b/tests/qemuagenttest.c
|
|
index b3d737d8a8..232b34f9cd 100644
|
|
--- a/tests/qemuagenttest.c
|
|
+++ b/tests/qemuagenttest.c
|
|
@@ -907,8 +907,8 @@ mymain(void)
|
|
{
|
|
int ret = 0;
|
|
|
|
-#if !WITH_STABLE_ORDERING_JANSSON
|
|
- fputs("libvirt not compiled with recent enough Jansson, skipping this test\n", stderr);
|
|
+#if !WITH_JANSSON
|
|
+ fputs("libvirt not compiled with JSON support, skipping this test\n", stderr);
|
|
return EXIT_AM_SKIP;
|
|
#endif
|
|
|
|
--
|
|
2.18.0
|
|
|