mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
29 lines
895 B
Diff
29 lines
895 B
Diff
From faedc1669cb4862020b572fdd013fbe7f5fb925c Mon Sep 17 00:00:00 2001
|
|
From: Christian Hesse <mail@eworm.de>
|
|
Date: Fri, 2 Sep 2022 13:37:51 +0200
|
|
Subject: [PATCH 1/1] kern/efi/mm: increase default heap size
|
|
|
|
The new dynamic memory allocation slows down grub startup. Try to
|
|
fix / work around by increasing the default heap size.
|
|
|
|
Signed-off-by: Christian Hesse <mail@eworm.de>
|
|
---
|
|
grub-core/kern/efi/mm.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/grub-core/kern/efi/mm.c b/grub-core/kern/efi/mm.c
|
|
index d290c9a76..598e6b6a2 100644
|
|
--- a/grub-core/kern/efi/mm.c
|
|
+++ b/grub-core/kern/efi/mm.c
|
|
@@ -39,7 +39,7 @@
|
|
#define MEMORY_MAP_SIZE 0x3000
|
|
|
|
/* The default heap size for GRUB itself in bytes. */
|
|
-#define DEFAULT_HEAP_SIZE 0x100000
|
|
+#define DEFAULT_HEAP_SIZE 0x1000000
|
|
|
|
static void *finish_mmap_buf = 0;
|
|
static grub_efi_uintn_t finish_mmap_size = 0;
|
|
--
|
|
2.37.3
|
|
|