mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
39 lines
1.1 KiB
Diff
39 lines
1.1 KiB
Diff
From 3903318b827a5d75830cde1cd7087294257fa298 Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Fri, 6 Feb 2015 05:40:56 -0700
|
|
Subject: [PATCH 2/2] odroid-x support
|
|
|
|
---
|
|
board/samsung/odroid/odroid.c | 2 +-
|
|
include/configs/odroid.h | 2 +-
|
|
2 files changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/board/samsung/odroid/odroid.c b/board/samsung/odroid/odroid.c
|
|
index 0df96c1a3d..3aa8d6c5b5 100644
|
|
--- a/board/samsung/odroid/odroid.c
|
|
+++ b/board/samsung/odroid/odroid.c
|
|
@@ -57,7 +57,7 @@ void set_board_type(void)
|
|
|
|
const char *get_board_type(void)
|
|
{
|
|
- const char *board_type[] = {"u3", "x2"};
|
|
+ const char *board_type[] = {"u3", "x"};
|
|
|
|
return board_type[gd->board_type];
|
|
}
|
|
diff --git a/include/configs/odroid.h b/include/configs/odroid.h
|
|
index caa1b03a22..c2ee43f2e1 100644
|
|
--- a/include/configs/odroid.h
|
|
+++ b/include/configs/odroid.h
|
|
@@ -22,7 +22,7 @@
|
|
|
|
#define CONFIG_MACH_TYPE 4289
|
|
|
|
-#define CONFIG_NR_DRAM_BANKS 8
|
|
+#define CONFIG_NR_DRAM_BANKS 4
|
|
#define CONFIG_SYS_SDRAM_BASE 0x40000000
|
|
#define SDRAM_BANK_SIZE (256 << 20) /* 256 MB */
|
|
#define PHYS_SDRAM_1 CONFIG_SYS_SDRAM_BASE
|
|
--
|
|
2.16.1
|
|
|