mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
54 lines
1.5 KiB
Diff
54 lines
1.5 KiB
Diff
From: Torsten Jager <t.jager@gmx.de>
|
|
Date: Thu, 16 Dec 2021 23:43:10 +0100
|
|
Subject: Fix build.
|
|
|
|
---
|
|
configure.ac | 6 ++++--
|
|
src/common/utils.h | 2 +-
|
|
src/xitk/network.c | 2 ++
|
|
3 files changed, 7 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 58342e0..8d7276e 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -600,8 +600,10 @@ int n = my_strlen ("what");
|
|
])], [have_attr_iaso=yes], [have_attr_iaso=no])
|
|
AC_MSG_RESULT([$have_attr_iaso])
|
|
if test x"$have_attr_iaso" = x"yes" ; then
|
|
- AC_DEFINE([ATTR_INLINE_ALL_STRINGOPS],
|
|
- [__attribute__ ((__target__ ("inline-all-stringops")))],
|
|
+ AC_DEFINE([ATTR_INLINE_ALL_STRINGOPS], [__attribute__ ((__target__ ("inline-all-stringops")))],
|
|
+ [Define this to a function attribute that inlines string handling code])
|
|
+else
|
|
+ AC_DEFINE([ATTR_INLINE_ALL_STRINGOPS], [],
|
|
[Define this to a function attribute that inlines string handling code])
|
|
fi
|
|
|
|
diff --git a/src/common/utils.h b/src/common/utils.h
|
|
index 8adad40..cfb2628 100644
|
|
--- a/src/common/utils.h
|
|
+++ b/src/common/utils.h
|
|
@@ -21,7 +21,7 @@
|
|
#ifndef _COMMON_UTILS_H
|
|
#define _COMMON_UTILS_H
|
|
|
|
-#ifndef HAVE_CONFIG_H
|
|
+#ifndef PACKAGE_NAME
|
|
#error config.h not included
|
|
#endif
|
|
|
|
diff --git a/src/xitk/network.c b/src/xitk/network.c
|
|
index 616400e..0fe39c5 100644
|
|
--- a/src/xitk/network.c
|
|
+++ b/src/xitk/network.c
|
|
@@ -34,7 +34,9 @@
|
|
|
|
//#warning IMPLEMENT POST SUPPORT
|
|
|
|
+#ifdef HAVE_CONFIG_H
|
|
#include "config.h"
|
|
+#endif
|
|
|
|
#ifdef HAVE_READLINE
|
|
|