mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
11 lines
333 B
Diff
11 lines
333 B
Diff
--- src/tools/qstring.h
|
|
+++ src/tools/qstring.h
|
|
@@ -195,6 +195,8 @@
|
|
ushort unicode() const { return ucs; }
|
|
#ifdef Q_NO_PACKED_REFERENCE
|
|
ushort &unicode() { return *(&ucs); }
|
|
+#elif defined Q_NO_PACKED_POINTERS
|
|
+ ushort &unicode() { ushort& tmp = ucs; return tmp; }
|
|
#else
|
|
ushort &unicode() { return ucs; }
|
|
#endif
|