mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
54 lines
2.1 KiB
Diff
54 lines
2.1 KiB
Diff
From 76a29148be63cb006a7e25e312dc93acc93e071f Mon Sep 17 00:00:00 2001
|
|
From: Stephan Bergmann <sbergman@redhat.com>
|
|
Date: Tue, 3 Jul 2018 08:33:34 +0200
|
|
Subject: [PATCH] const fixes for python3-devel-3.7.0-1.fc29.x86_64
|
|
|
|
Change-Id: Ia16a8b828e11ce36e9bb77ecf9e8a1179bd9b90c
|
|
Reviewed-on: https://gerrit.libreoffice.org/56841
|
|
Tested-by: Jenkins
|
|
Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
|
|
---
|
|
pyuno/source/module/pyuno_impl.hxx | 2 +-
|
|
pyuno/source/module/pyuno_type.cxx | 2 +-
|
|
pyuno/source/module/pyuno_util.cxx | 2 +-
|
|
3 files changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/pyuno/source/module/pyuno_impl.hxx b/pyuno/source/module/pyuno_impl.hxx
|
|
index ea0e419ffb1b..73acabdf4a16 100644
|
|
--- a/pyuno/source/module/pyuno_impl.hxx
|
|
+++ b/pyuno/source/module/pyuno_impl.hxx
|
|
@@ -80,7 +80,7 @@ inline PyObject* PyStr_FromString(const char *string)
|
|
return PyUnicode_FromString(string);
|
|
}
|
|
|
|
-inline char * PyStr_AsString(PyObject *object)
|
|
+inline char const * PyStr_AsString(PyObject *object)
|
|
{
|
|
return PyUnicode_AsUTF8(object);
|
|
}
|
|
diff --git a/pyuno/source/module/pyuno_type.cxx b/pyuno/source/module/pyuno_type.cxx
|
|
index c6fc1351436b..80505d85bbd1 100644
|
|
--- a/pyuno/source/module/pyuno_type.cxx
|
|
+++ b/pyuno/source/module/pyuno_type.cxx
|
|
@@ -157,7 +157,7 @@ Any PyEnum2Enum( PyObject *obj )
|
|
}
|
|
|
|
OUString strTypeName( OUString::createFromAscii( PyStr_AsString( typeName.get() ) ) );
|
|
- char *stringValue = PyStr_AsString( value.get() );
|
|
+ char const *stringValue = PyStr_AsString( value.get() );
|
|
|
|
TypeDescription desc( strTypeName );
|
|
if( !desc.is() )
|
|
diff --git a/pyuno/source/module/pyuno_util.cxx b/pyuno/source/module/pyuno_util.cxx
|
|
index 45ee5a38e40b..f9714fb270f0 100644
|
|
--- a/pyuno/source/module/pyuno_util.cxx
|
|
+++ b/pyuno/source/module/pyuno_util.cxx
|
|
@@ -69,7 +69,7 @@ OUString pyString2ustring( PyObject *pystr )
|
|
#else
|
|
#if PY_MAJOR_VERSION >= 3
|
|
Py_ssize_t size(0);
|
|
- char *pUtf8(PyUnicode_AsUTF8AndSize(pystr, &size));
|
|
+ char const *pUtf8(PyUnicode_AsUTF8AndSize(pystr, &size));
|
|
ret = OUString(pUtf8, size, RTL_TEXTENCODING_UTF8);
|
|
#else
|
|
PyObject* pUtf8 = PyUnicode_AsUTF8String(pystr);
|