PKGBUILDs/community/gitea/gitea-arch-defaults.patch
2021-07-19 12:53:44 -04:00

52 lines
1.7 KiB
Diff

--- a/custom/conf/app.example.ini
+++ b/custom/conf/app.example.ini
@@ -9,7 +9,7 @@
; App name that shows in every page title
APP_NAME = Gitea: Git with a cup of tea
; Change it if you run locally
-RUN_USER = git
+RUN_USER = gitea
; Application run mode, affects performance and debugging. Either "dev", "prod" or "test", default is "prod"
RUN_MODE = prod
@@ -20,7 +20,7 @@ PROJECT_BOARD_BUG_TRIAGE_TYPE = Needs Triage, High Priority, Low Priority, Close
[repository]
; Root path for storing all repository data. It must be an absolute path. By default it is stored in a sub-directory of `APP_DATA_PATH`.
-ROOT =
+ROOT = /var/lib/gitea/repos
; The script type this server supports. Usually this is `bash`, but some users report that only `sh` is available.
SCRIPT_TYPE = bash
; DETECTED_CHARSETS_ORDER tie-break order for detected charsets.
@@ -442,7 +442,7 @@ SQLITE_TIMEOUT = 500
; For iterate buffer, default is 50
ITERATE_BUFFER_SIZE = 50
; Show the database generated SQL
-LOG_SQL = true
+LOG_SQL = false
; Maximum number of DB Connect retries
DB_RETRIES = 10
; Backoff time per DB retry (time.Duration)
@@ -875,10 +875,10 @@ FORMAT =
DEFAULT_UI_LOCATION =
[log]
-ROOT_PATH =
+ROOT_PATH = /var/log/gitea/
; Either "console", "file", "conn", "smtp" or "database", default is "console"
; Use comma to separate multiple modes, e.g. "console, file"
-MODE = console
+MODE = console, file
; Buffer length of the channel, keep it as it is if you don't know what it is.
BUFFER_LEN = 10000
; Either "Trace", "Debug", "Info", "Warn", "Error", "Critical", default is "Info"
@@ -901,7 +901,7 @@ COLORIZE = false
; For "console" mode only
[log.console]
-LEVEL =
+LEVEL = Info
STDERR = false
; For "file" mode only