mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
57 lines
1.7 KiB
Diff
57 lines
1.7 KiB
Diff
From eee9ff0228f52008bfc565241f6dfe07ae7a7044 Mon Sep 17 00:00:00 2001
|
|
From: Andreas Schneider <asn@samba.org>
|
|
Date: Tue, 2 Aug 2022 07:55:46 +0200
|
|
Subject: [PATCH] lib:replace: Only include <sys/mount.h> on non-Linux systems
|
|
|
|
Details at:
|
|
https://sourceware.org/glibc/wiki/Release/2.36#Usage_of_.3Clinux.2Fmount.h.3E_and_.3Csys.2Fmount.h.3E
|
|
|
|
BUG: https://bugzilla.samba.org/show_bug.cgi?id=15132
|
|
|
|
Signed-off-by: Andreas Schneider <asn@samba.org>
|
|
Reviewed-by: Ralph Boehme <slow@samba.org>
|
|
(cherry picked from commit 766151bf5b7ef95ae4c8c98b8994e5c21c5bbec0)
|
|
---
|
|
lib/replace/system/filesys.h | 4 +++-
|
|
lib/replace/wscript | 3 +++
|
|
2 files changed, 6 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/lib/replace/system/filesys.h b/lib/replace/system/filesys.h
|
|
index 034e5d5886c..bb9482c69af 100644
|
|
--- a/lib/replace/system/filesys.h
|
|
+++ b/lib/replace/system/filesys.h
|
|
@@ -36,7 +36,8 @@
|
|
#include <sys/param.h>
|
|
#endif
|
|
|
|
-#ifdef HAVE_SYS_MOUNT_H
|
|
+/* This include is required on UNIX (*BSD, AIX, ...) for statfs() */
|
|
+#if !defined(LINUX) && defined(HAVE_SYS_MOUNT_H)
|
|
#include <sys/mount.h>
|
|
#endif
|
|
|
|
@@ -44,6 +45,7 @@
|
|
#include <mntent.h>
|
|
#endif
|
|
|
|
+/* This include is required on Linux for statfs() */
|
|
#ifdef HAVE_SYS_VFS_H
|
|
#include <sys/vfs.h>
|
|
#endif
|
|
diff --git a/lib/replace/wscript b/lib/replace/wscript
|
|
index e4c2d513076..0db93d8caf1 100644
|
|
--- a/lib/replace/wscript
|
|
+++ b/lib/replace/wscript
|
|
@@ -31,6 +31,9 @@ def configure(conf):
|
|
|
|
conf.env.standalone_replace = conf.IN_LAUNCH_DIR()
|
|
|
|
+ if sys.platform.rfind('linux') > -1:
|
|
+ conf.DEFINE('LINUX', '1')
|
|
+
|
|
conf.DEFINE('BOOL_DEFINED', 1)
|
|
conf.DEFINE('HAVE_LIBREPLACE', 1)
|
|
conf.DEFINE('LIBREPLACE_NETWORK_CHECKS', 1)
|
|
--
|
|
2.37.1
|
|
|