mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
12 lines
382 B
Diff
12 lines
382 B
Diff
diff -Nur gd-2.0.36RC1.orig/gd_png.c gd-2.0.36RC1/gd_png.c
|
|
--- gd-2.0.36RC1.orig/gd_png.c 2007-11-27 10:30:34.000000000 +0200
|
|
+++ gd-2.0.36RC1/gd_png.c 2010-01-17 17:14:11.000000000 +0200
|
|
@@ -151,7 +151,7 @@
|
|
return NULL;
|
|
}
|
|
|
|
- if (!png_check_sig (sig, 8)) { /* bad signature */
|
|
+ if (png_sig_cmp (sig, 0, 8)) { /* bad signature */
|
|
return NULL; /* bad signature */
|
|
}
|
|
|