mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
33 lines
962 B
Diff
33 lines
962 B
Diff
From a0840cc2f621e04af5751224e64b89ea0d39bf00 Mon Sep 17 00:00:00 2001
|
|
From: Adam Jackson <ajax@redhat.com>
|
|
Date: Tue, 19 Jul 2016 10:21:03 -0400
|
|
Subject: [PATCH 1/2] Adapt Block/WakeupHandler signature for ABI 23
|
|
|
|
Signed-off-by: Adam Jackson <ajax@redhat.com>
|
|
---
|
|
src/compat-api.h | 6 ++++++
|
|
1 file changed, 6 insertions(+)
|
|
|
|
diff --git a/src/compat-api.h b/src/compat-api.h
|
|
index fefbc59..78d3c91 100644
|
|
--- a/src/compat-api.h
|
|
+++ b/src/compat-api.h
|
|
@@ -77,9 +77,15 @@
|
|
|
|
#define SCREEN_INIT_ARGS_DECL ScreenPtr pScreen, int argc, char **argv
|
|
|
|
+#if ABI_VIDEODRV_VERSION >= SET_ABI_VERSION(23, 0)
|
|
+#define BLOCKHANDLER_ARGS_DECL \
|
|
+ ScreenPtr arg, pointer pTimeout
|
|
+#define BLOCKHANDLER_ARGS arg, pTimeout
|
|
+#else
|
|
#define BLOCKHANDLER_ARGS_DECL \
|
|
ScreenPtr arg, pointer pTimeout, pointer pReadmask
|
|
#define BLOCKHANDLER_ARGS arg, pTimeout, pReadmask
|
|
+#endif
|
|
|
|
#define CLOSE_SCREEN_ARGS_DECL ScreenPtr pScreen
|
|
#define CLOSE_SCREEN_ARGS pScreen
|
|
--
|
|
2.11.0
|
|
|