mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
fd9654dba5
Upsteam patch information:
3067779b15
13 lines
490 B
Diff
13 lines
490 B
Diff
diff --git a/drivers/usb/musb/musb_host.c b/drivers/usb/musb/musb_host.c
|
|
index 4bb717d..1ae378d 100644
|
|
--- a/drivers/usb/musb/musb_host.c
|
|
+++ b/drivers/usb/musb/musb_host.c
|
|
@@ -2049,7 +2049,7 @@ static int musb_urb_enqueue(
|
|
* we only have work to do in the former case.
|
|
*/
|
|
spin_lock_irqsave(&musb->lock, flags);
|
|
- if (hep->hcpriv) {
|
|
+ if (hep->hcpriv || !next_urb(qh)) {
|
|
/* some concurrent activity submitted another urb to hep...
|
|
* odd, rare, error prone, but legal.
|
|
*/
|