mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
30 lines
947 B
Diff
30 lines
947 B
Diff
From 51c93162de459b14ebf07445c87aaf8ba3795b07 Mon Sep 17 00:00:00 2001
|
|
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
|
Date: Mon, 14 Jan 2019 21:33:29 -0700
|
|
Subject: [PATCH 2/3] Revert "Signature of rb_uint2inum and rb_int2inum"
|
|
|
|
This reverts commit b2033b8b8418b0c1ceed54bdc170c03dd45d1cf8.
|
|
---
|
|
include/ruby/ruby.h | 4 ++--
|
|
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/include/ruby/ruby.h b/include/ruby/ruby.h
|
|
index 697ea7f45d..c7c873e1c8 100644
|
|
--- a/include/ruby/ruby.h
|
|
+++ b/include/ruby/ruby.h
|
|
@@ -263,10 +263,10 @@ typedef char ruby_check_sizeof_voidp[SIZEOF_VOIDP == sizeof(void*) ? 1 : -1];
|
|
#define RB_LONG2FIX(i) RB_INT2FIX(i)
|
|
#define LONG2FIX(i) RB_INT2FIX(i)
|
|
#define rb_fix_new(v) RB_INT2FIX(v)
|
|
-VALUE rb_int2inum(intptr_t);
|
|
+VALUE rb_int2inum(SIGNED_VALUE);
|
|
|
|
#define rb_int_new(v) rb_int2inum(v)
|
|
-VALUE rb_uint2inum(uintptr_t);
|
|
+VALUE rb_uint2inum(VALUE);
|
|
|
|
#define rb_uint_new(v) rb_uint2inum(v)
|
|
|
|
--
|
|
2.20.1
|
|
|