PKGBUILDs/community/percona-server/gcc7-fixes.patch
2017-08-02 12:48:56 +00:00

27 lines
1.1 KiB
Diff

diff --git a/storage/innobase/row/row0sel.cc b/storage/innobase/row/row0sel.cc
index 924ccd3..d5ce802 100644
--- a/storage/innobase/row/row0sel.cc
+++ b/storage/innobase/row/row0sel.cc
@@ -5221,7 +5221,7 @@ rec_loop:
reporting due to search views etc. */
if (prev_rec != NULL
&& prebuilt->m_mysql_handler->end_range != NULL
- && prebuilt->idx_cond == false && end_loop >= 100) {
+ && !prebuilt->idx_cond && end_loop >= 100) {
dict_index_t* key_index = prebuilt->index;
bool clust_templ_for_sec = false;
diff --git a/sql-common/client_authentication.cc b/sql-common/client_authentication.cc
index eaeb2d4..035ecd2 100644
--- a/sql-common/client_authentication.cc
+++ b/sql-common/client_authentication.cc
@@ -84,7 +84,7 @@ RSA *rsa_init(MYSQL *mysql)
if (mysql->options.extension != NULL &&
mysql->options.extension->server_public_key_path != NULL &&
- mysql->options.extension->server_public_key_path != '\0')
+ mysql->options.extension->server_public_key_path[0] != '\0')
{
pub_key_file= fopen(mysql->options.extension->server_public_key_path,
"r");