PKGBUILDs/core/binutils/binutils-2.24-CVE-2014-8503.patch
2014-11-19 01:17:19 +00:00

17 lines
334 B
Diff

diff --git a/bfd/ihex.c b/bfd/ihex.c
index 8d3590d..9b3b813 100644
--- a/bfd/ihex.c
+++ b/bfd/ihex.c
@@ -321,7 +321,7 @@ ihex_scan (bfd *abfd)
{
if (! ISHEX (buf[i]))
{
- ihex_bad_byte (abfd, lineno, hdr[i], error);
+ ihex_bad_byte (abfd, lineno, buf[i], error);
goto error_return;
}
}
--
1.7.1