PKGBUILDs/community/glpng/libglpng-1.45-debian.patch
2009-10-09 21:15:33 -05:00

29 lines
794 B
Diff

diff -up libglpng-1.45.orig libglpng-1.45
diff -up libglpng-1.45.orig/src/glpng.c.orig libglpng-1.45.orig/src/glpng.c
--- libglpng-1.45.orig/src/glpng.c.orig 2000-07-10 21:27:10.000000000 +0200
+++ libglpng-1.45.orig/src/glpng.c 2009-05-17 23:02:38.000000000 +0200
@@ -29,7 +29,7 @@
#include <GL/gl.h>
#include <stdlib.h>
#include <math.h>
-#include "png/png.h"
+#include <png.h>
/* Used to decide if GL/gl.h supports the paletted extension */
#ifdef GL_COLOR_INDEX1_EXT
@@ -113,6 +113,7 @@ static void Resize(int components, const
}
}
+#ifdef _WIN32
static int ExtSupported(const char *x) {
static const GLubyte *ext = NULL;
const char *c;
@@ -129,6 +130,7 @@ static int ExtSupported(const char *x) {
return 0;
}
+#endif
#define GET(o) ((int)*(data + (o)))