PKGBUILDs/extra/snes9x/snes9x-1.51-glibc2.10.patch
2009-10-09 21:23:22 -05:00

13 lines
295 B
Diff

--- unix/unix.cpp
+++ unix/unix.cpp
@@ -1162,8 +1162,8 @@
{
*drive = 0;
- char *slash = strrchr(path, SLASH_CHAR);
- char *dot = strrchr(path, '.');
+ char *slash = strrchr((char *)path, SLASH_CHAR);
+ char *dot = strrchr((char *)path, '.');
if (dot && slash && dot < slash)
{