mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
34 lines
1.2 KiB
Diff
34 lines
1.2 KiB
Diff
From 795af7a613e7aa678d1b6cab0cb40d6e46f06798 Mon Sep 17 00:00:00 2001
|
|
From: Srinivas Kandagatla <srinivas.kandagatla@linaro.org>
|
|
Date: Mon, 4 Jul 2016 10:21:48 +0100
|
|
Subject: [PATCH 2/2] sound: lpass-cpu: add module licence and description
|
|
|
|
This patch adds module licence to lpass-cpu driver, without this
|
|
patch lpass-cpu module would taint with below error:
|
|
|
|
snd_soc_lpass_cpu: module license 'unspecified' taints kernel.
|
|
Disabling lock debugging due to kernel taint
|
|
snd_soc_lpass_cpu: Unknown symbol regmap_write (err 0)
|
|
snd_soc_lpass_cpu: Unknown symbol devm_kmalloc (err 0)
|
|
...
|
|
|
|
Acked-by: Kenneth Westfield <kwestfie@codeaurora.org>
|
|
Signed-off-by: Srinivas Kandagatla <srinivas.kandagatla@linaro.org>
|
|
---
|
|
sound/soc/qcom/lpass-cpu.c | 3 +++
|
|
1 file changed, 3 insertions(+)
|
|
|
|
diff --git a/sound/soc/qcom/lpass-cpu.c b/sound/soc/qcom/lpass-cpu.c
|
|
index 3cde9fb..eff3f9a 100644
|
|
--- a/sound/soc/qcom/lpass-cpu.c
|
|
+++ b/sound/soc/qcom/lpass-cpu.c
|
|
@@ -586,3 +586,6 @@ int asoc_qcom_lpass_cpu_platform_remove(struct platform_device *pdev)
|
|
return 0;
|
|
}
|
|
EXPORT_SYMBOL_GPL(asoc_qcom_lpass_cpu_platform_remove);
|
|
+
|
|
+MODULE_DESCRIPTION("QTi LPASS CPU Driver");
|
|
+MODULE_LICENSE("GPL v2");
|
|
--
|
|
2.10.0
|
|
|