PKGBUILDs/alarm/uboot-odroid-c1/0002-sd_fusing-tweaks.patch
2016-11-26 18:15:09 +00:00

42 lines
1 KiB
Diff

From f4c89d91d5defcaa6aed1371c2dac62c7d1da1f4 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Mon, 22 Dec 2014 09:55:32 -0700
Subject: [PATCH 02/11] sd_fusing tweaks
---
sd_fuse/sd_fusing.sh | 13 ++++++-------
1 file changed, 6 insertions(+), 7 deletions(-)
diff --git a/sd_fuse/sd_fusing.sh b/sd_fuse/sd_fusing.sh
index f0ce95a..f65980a 100755
--- a/sd_fuse/sd_fusing.sh
+++ b/sd_fuse/sd_fusing.sh
@@ -12,18 +12,17 @@ if [ -z $1 ]; then
fi
if [ ! -f $BL1 ]; then
- echo "Error: $BL1 is not exist."
+ echo "Error: $BL1 does not exist."
exit 0
fi
if [ ! -f $UBOOT ]; then
- echo "Error: $UBOOT is not exist."
+ echo "Error: $UBOOT does not exist."
exit 0
fi
-sudo dd if=$BL1 of=$1 bs=1 count=442
-sudo dd if=$BL1 of=$1 bs=512 skip=1 seek=1
-sudo dd if=$UBOOT of=$1 bs=512 seek=64
+dd if=$BL1 of=$1 bs=1 count=442
+dd if=$BL1 of=$1 bs=512 skip=1 seek=1
+dd if=$UBOOT of=$1 bs=512 seek=64
sync
-sudo eject $1
-echo FINISH
+echo "Successfully wrote U-Boot to $1"
--
2.10.2